21

I use Google Remote Desktop using the Chrome web application to connect to a remote server.

Problem: I am unable to copy and paste host to remote server. How to enable it?

17

On the right side of Chrome Remote Desktop, the small blue arrow has Keyboard controls and its submenu has the option to enable the clipboard.

3
14

Screenshots illustrating sunil shakya's answer:

Step 1: Open Keyboard Controls menu on Google Remote Desktop

Step 2: Enable clipboard synchronization:

enter image description here

enter image description here

3
  • 5
    This is totally broken for me. The option is no longer available even though it was working fine yesterday, last week, and earlier today.
    – user24601
    Apr 23 '20 at 19:38
  • 1
    please upvote question & answers. I've forgotten this once already .. back for a second bite of the cherry. works on windows 10 to mint for my July 2020
    – zzapper
    Jul 16 '20 at 6:39
  • 1
    I feel bad I had to look this up, because reading is hard :( tyvm tho!
    – Jared
    Dec 13 '20 at 5:16
2

Took me a while to check how to copy-paste from Windows into a Mac via Google Remote Desktop.

  • Open the Session options via the arrow, select Configure key mappings and map:

    From To
    ControlLeft MetaLeft
1

Chrome Remote Desktop can do it all. It will do the copy/paste keyboard shortcuts via the usual CTRL-C CTRL V.

And will do file upload/download via the links on the left panel:

1
  • Fine for text. But file transfer must be done via the upload/download link on the "right-side" remote desktop menu. And the file go to the desktop. Feb 23 '21 at 10:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.