5

I have a number of smb v1 shares. (I know that smbv1 is old and vulnerable but I can't change it) Because of the old smb protocol, I cannot use nautilus to open then. Instead, I used fstab entries to mount them. The entries in /etc/fstab look like this:

//smbserver/folder /media/user/smbserver/folder cifs credentials=/home/user/.smbcredentials,vers=1.0,noauto,user 0 0

On a Mint 19 machine, this worked like a charm, but on a new Fedora 30 installation, I only get the following error:

$ mount /media/user/smbserver/folder
This program is not installed setuid root -  "user" CIFS mounts not supported.

I already tried to set the suid bit for /usr/bin/mount, but this did not change anything.

How can I mount the smb shares on Fedora 30?

9

Ok, found out myself.

The following programs needed to have the suid bit set (sudo chmod u+s /bin/...):

/bin/mount
/bin/umount
/usr/sbin/mount.cifs

Some Distros do this by default. However, there seems to be discussion about the security (s-bit is always problematic).

1
  • Thanks for your solution. This works for NFS as well.
    – John Jiang
    May 5 '21 at 6:44
0

Also make sure to check that the file home/user/.smbcredentials is accessible to you. I created mine with root which caused me issues.

But what ultimately helped me solve the issue was your advice on setting the suid bit on /usr/sbin/mount.cifs.

New contributor
chrome is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
1
  • 1
    As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center.
    – Community Bot
    11 hours ago

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.