35

After the recent Windows update, this Ctrl+Alt+Shift+F hotkey combination is reserved by Windows, I have even checked in safe mode where no other programs are running. I cannot register this combination in any program I use now. Besides, it's super annoying; I don't understand what it does and how I can change it.

7
  • 1
    Must be new, it does not appear on the official keyboard shortcuts list anywhere....support.microsoft.com/en-us/help/12445/…
    – Moab
    Commented Jun 6, 2019 at 15:36
  • @Moab have you got this Windows version? Is it the same for you?
    – vitr
    Commented Jun 7, 2019 at 1:05
  • 1
    I noticed this as well. I previously used this as "Find In Files" in Visual Studio, and now it doesn't work. I used Hotkey Explorer to test it and it says it's registered to an unknown program (presumably a low-level Windows hook) but it doesn't appear to do anything.
    – Arcanox
    Commented Jul 26, 2019 at 14:20
  • 1
    Sheesh this is annoying... same with Intellij's terraform fmt. Commented Aug 13, 2019 at 19:56
  • 4
    I have just spent several hours trying to find what new application is hogging this hotkey, but no luck. For me the problem is worse. I use a non-US keyboard and now cannot type the key mapped to AltGr+Shift+F. AltGr, or the right Alt key, is used on international keyboards to type non-ASCII characters. It is effectively the same as Ctrl+Alt, which means that this hidden Ctrl+Alt+Shift+F hotkey prevents typing this character.
    – Barnett
    Commented Sep 12, 2019 at 11:36

1 Answer 1

26
+100

This problem is reported on several support forums for products that use this key combination. According to all reports this is a problem introduced by the update to Windows 10 version 1903, when this key is swallowed up by Windows without doing anything.

It may be undone in a future update, or Microsoft will complete adding the handling of this new hotkey, but in the meantime here is what I found.

Using Spy++ I saw this funny sequence of events being reported for pressing these keys:

Ctrl down
Shift down
Alt down
F up
Alt up
Ctrl up
Shift up

Meaning that the event for "F down" was swallowed up by some component of Windows. If these three modifier keys are pressed then the result is that the F-key event is totally nullified.

I then tried AutoHotkey to intercept this key sequence, and this worked. Apparently, AutoHotkey hooks the keyboard at a lower level than whatever Windows component that swallows up the F-key, so is able to intercept and handle it first.

For associating this key-sequence with running Explorer, you could use this AutoHotkey script:

!^+F:: Run, explorer.exe

After installing AutoHotKey, put the above text in a .ahk file and double-click it to test. You may stop the script by right-click on the green H icon in the traybar and choosing Exit. If you always want this script to execute, copy it to the user Startup folder at C:\Users\<user name>\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup.

3
  • 1
    I've spent 2 days on it. downloaded almost every software of hotkeys recognition : none.
    – Royi Namir
    Commented Oct 22, 2019 at 18:46
  • 1
    I first noticed this after I upgraded Visual Studio and a shortcut I had stopped working. So I logged a report with the VS team: report and they referred me to this question :D Commented Jan 16, 2020 at 13:18
  • It is still not working even today, it is so annoying, I was so used to CTRL+ALT+SHIFT+F shortcut for formatting codes in VS2019 and now I have to change it to other sequence. Commented Jul 20, 2020 at 15:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .