0

I am a newbie in web development. My company needs a SSL Certificate for its website and I seem to be struggling a bi t. I followed amazons verification steps, and used the provided DNS record into my godaddy DNS settings.

For Example: GIVEN
Domain Name: www.example.com
Record NAME: _12123blah.www.example.com
Record Value: _blahblahblah.aws.

I pasted this into the DNS CNAME record excluding my domain www.example.com for the Record Name.

By following these steps I was not directed to any new steps. I was wondering how long does the verification take, or am I supposed to wait for an email to my goDaddy account? I have been stuck for hrs now thank you and extra help is appreciated.

4
  • ACM is normally pretty quick if doing dns based authentication (though I've only used route53 not godaddy dns). Check the ACM console, the status should be "issued", if not it should let you retry/tell you the problem. Once it's issued you can use the cert on a aws load balencer and cloudfront etc (you cant download the cert to install elsewhere) – MisterSmith Jun 7 '19 at 19:00
  • Ok so it doesnt change at all. It just says pending. – Naman Jain Jun 12 '19 at 10:17
  • @MisterSmith Do you know by any chance if what I have put in the question above as the params for the DNS is correct? Should I remove the example.com? Should I keep www ? Really no idea as I have tried various variations for this now. – Naman Jain Jun 12 '19 at 11:26
  • Go to toolbox.googleapps.com/apps/dig/#CNAME and paste in the CNAME (_12123blah.www.example.com etc) - this ensures the CNAME is visible from the internet/by ACM. If the DNS has propagated you should see the CNAME, time-to-live and destination in the output between lines ";ANSWER" and ";AUTHORITY". I think its either theres a mistake in your DNS (double check the destination returned is exactly what your expecting), GoDaddy is really slow updating (if the entry isnt visible), or ACM is really slow updating. If your DNS is correct and visible to DIG, ACM should have no issue. – MisterSmith Jun 12 '19 at 19:06
0

I found the answer to my own problem. Instead of excluding www.example.com I only excluded example.com

So for the recordname i used _12123blah.www . This solved my problem.

FYI it took me 2 mins of waiting afterwards and I got my verification soon after.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.