0

I tried to upgrade my dad's computer by switching the ram module from 4gb to one with 8gb. I press the power button, the leds light up, then comes one short beep and there is nothing on the screen.

The computer is a HP ProOne 400 G1 All-in-One PC (link to all docs) with a (completely) broken display, so he uses the pc with a second monitor.

This is the ram: 8gb hyperx impact 1600mhz sodimm ddr3 (cl9). It has the same frequency and voltage than the original ram, only the cl is lower (9 vs 11). (This could be a problem?)

This is exactly what I did: I opened the computer, replaced the ram module and turned it back on. It didn't boot so I read online that I should have reseted the cmos before putting the new ram. So I took the new ram out, reseted the cmos and putted back on. Nothing. Then I putted the old ram back on and also nothing. (I tried the old ram on both slots). I tried a few more times and also removed the battery from the mobo instead of pressing the reset cmos button on some of the attempts.

First I thought that the beep could be a error message, but acording to the Maintenance & Service Manual, there is no error code with just one beep, so I think that maybe it's a normal sound? (My dad is 65 yo, he does not remember if the computer beeped on startup) And also there is no red light blinking (in contrast to what happens when I try booting with no ram modules, which gives me red light blinks and 5 beeps).

As the screen is broken, I'm not sure if it is possible to acess the bios because I don't know in what part of the startup the second monitor starts receving the image.

I'm reaching out to you guys to see if anyone has any ideia of what can be happening. What exactly happens when the reset cmos button is pressed? Or the battery removed from the mobo? Shouldn't the old ram module work?

(Nothing seems broken. Nothing smells burnt.)

3
  • 1
    HP Laptops and AIOs often require a BIOS upgrade to handle additional memory. generally this would allow you to put the old ram back in to run the update (which has to be obtained from Support, generally). resetting the CMOS is likely to be the issue there. not sure what to recommend if you can't access the bios to set it back up. you can try looking up what button launches Setup at boot, and mash it for a bit right after powering on. then wait a minute and hit F10 (save and exit) followed by enter a couple seconds later. the goal is to open setup, and save defaults to the cmos. worth a try. – Frank Thomas Jun 8 '19 at 3:17
  • 1
    also note, for laptops and AIOs, and anything else that isn't made to be user serviceable, the components often have less isolation from each other. as such, the broken screen is perhaps a bigger deal than it would be on a desktop where the monitor just doesn't emit signal or metadata. – Frank Thomas Jun 8 '19 at 3:20
  • Oh, I guess that would explain things. Thank you! I should have researched more... – vrcoelho Jun 8 '19 at 5:03
0

Lower CAS latency should not be a problem (on the contrary, new RAM is slightly faster). Crucial says this model can take 16 gigs, 8 per slot.

By what you describe, the computer probably works. This is a shot in the dark :) but it could be using the default display on boot, since you reset the BIOS to defaults. Some PCs boot with working internal and external video, but others you can choose... yes, in the BIOS...

I think this bit in Getting Started confirms it:

If the system has multiple video sources (embedded, PCI, or PCI-Express adapters) installed (embedded video on some models only) and a single monitor, the monitor must be connected to the monitor port on the source that is set as the primary video source. During boot, the other video ports are disabled; if the monitor is connected to one of these ports, the monitor will not function. You can select or change the primary video source in Computer Setup

Edit: on second thought, this is talking about a second video card, which you probably don't have... still, you could try blind BIOS for a bit before you try the disassembly option:

Try:

  • Do you have a video output button like in laptops, or more than one video output to try? (I'm guessing no, but couldn't hurt to ask xD).
  • Confirm computer is working:
    • Hard drive blinking with activity or making noise?
    • Can you restart the computer blindly from the BIOS? (press F10 repeatedly for five seconds after powering on, wait another five seconds, press F10 again, then Enter to save and restart)
  • Find screenshots/video/a PC with a similar BIOS so you can navigate it blindly to switch primary video. From the Maintenance & Service Guide:
    • Computer Setup—Advanced > VGA Configuration: Displayed only if there is an add-in video card in the system. Allows you to specify which VGA controller will be the “boot” or primary VGA controller.
  • Disassemble PC and unplug screen to force external video (probably hard work, knowing HP and AiOs... example with an HP laptop)

Edit: The BIOS in this post looks similar enough: BIOS Advanced > VGA Configuration

So you could try this:

  • Press F10 repeatedly for five seconds after powering on, wait another five seconds.
  • Press right arrow four times (this assumes File is selected by default; it could be five times... search for a video with a similar BIOS to know for sure )
  • Press down five times (again, assuming first option is preselected...)
  • Press up (try down next time if this doesn't work)
  • Press F5 to set as primary, F10 to accept, F10 and Enter to save and restart
  • Fingers crossed!

BIOS info screen: ProOne BIOS System Info

P.S: I'm not 65 yo, but I wouldn't remember if my computer bleeps either. ;)

1
  • Wow. Such a complete answer. Thank you! I'll try your suggestions. – vrcoelho Jun 8 '19 at 5:06
0

Here is the answer for me.

Same issue. Upgraded to 32 gig from 16 same speed and DDR type as the 16 gig that was in there. Easy right? Wrong.

All kinds of Windows errors upon restart. Bios and Windows 10 saw the 32 (when Windows booted). Mostly I got various error messages from Windowsi that it computer ran into a problem. Windows diagnostic tool also reported a problem but couldn’t repair.

Solution: check your motherboard specs for compatible memory by the specific manufacturer with the CPU you have. In my case, while the Corsair 64 gig configuration was compatible the 32 on exactly the same spec was not. There are almost no 32 gig configurations for the Ryzen 7 3700x on this Mobo (ASRock B550m ac) that can run at 3600. Swaped back the old memory to confirm and I was right.

Back if goes (hopefully) for two 16 sticks that are on the compatible list.

Save yourself the time and frustration check the compatible memory for your exact set up and specific manufacturer you are looking at and do not assume just because it’s DDR 4 3600 that it will work. Pangoly.com confirmed what ASRock site said too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.