2

I hope I'm not asking this in the wrong place but here goes anyway,

So, wanted a cheap portable ms surface clone which I bought in the Kogan atlas go 13.3, as seen here.

Long story short, I received it and once set up found the 'task view' did not function correctly either by clicking the button next to Cortana or using the Win + Tab keys. All the computer would do is refresh the desktop. Spoke to MS support and was ultimately directed to download a new copy of windows and install it form a bootable USB, which I did.

Now this solved my initial problem regarding the task view not working, but has caused an even bigger issue in that now the touch screen doesn't respond to touch inputs and was showing as an unrecognised device in device manager.

I've spoken to Kogan support and they directed me to the website below to re-install drivers, (I'm going to include the link as I could not find it at all via Google or their website initially, just in case anyone else needs the drivers in future, find it here but unfortunately there was no touch driver included.

The bios (screenshot included) lists a number of touch panel options, each of which have their own drivers available online although as far as my research and troubleshooting has found only the goodix, elan and silead touch devices seem to work in any way or at the very least show as a HID compliant touch I2C device.

I've literally been through the entire MS update catalogue for each of the three aforementioned touch devices and tried installing them all through device manager.

I will mention as well that if I load optimised defaults in the bios the silead touch device is the one it selects by default. Either way though regardless of what I choose, the drivers tend to either not work at all, cause random phantom touch inputs all over the screen or, like the one I have currently installed (which is one that Driver Talent found; yes I know driver installers aren't the best options but hey I've gotten desperate here lol) which is the closest I've actually had to a working touch screen since MS support got me to download and reinstall their damn fresh copy of windows from their website.

Anyway with this current silead driver version I'm using the behaviour of the touch is consistent at least; for e.g if I touch the very center of the screen its bang on perfect but if I touch say two inch's left of center the input is registered two inches right of center. The same behaviour occurs all around the screen, if I touch at say a 45 deg angle from center in the top left it will register at the same point on the screen but in the bottom right. Basically it seems the pc is inverting my selections, and that the input is directly proportional to where my finger presses, just on the opposite side, if that makes sense.

So I'm wondering if anyone out there;

a) has the correct drivers for the specific silead touch device that would be inbuilt in this (let me know if can provide further information to help determine the exact specs),

b) could potentially rework the parameters of this current driver I have (happy to provide it) so that it re inverts my inputs (don't even know if that's possible)

or c) has a recovery image ISO that I could grab so I can just create a bootable usb a reset it to its factory state. Oh how I wish id done that first!

Thanks in advance, hopefully someone out there who knows a lot more than I can help me get this fixed!

Cheers, Julian

enter image description here

EDIT: ok so after doing some more research I've found this post from someone else who had a similar issue but with the goodix touch device. Ultimately he fixed his problem by editing a config file to un-invert his touch but I can not for the life of me find a similar config file for the Silead KMDF HID minidriver for touch I2C; any ideas on if there's a way to do what he did to fix the problem or perhaps what the equivalent file is called for Silead devices?

4
  • Oof. Yea, the first rule with these off-brand devices is to take a full image backup of the original OS in case you need to extract drivers later, but it's probably too late for that. First, you should try to confirm the touchscreen hardware - the firmware options won't help here - go to the WIndows device manager, identify the device (maybe "unknown device" if you don't have [wrong] drivers installed) and check the Details tab, "Hardware IDs" option. This should give you a VEN and DEV ID that'll get you partway there. – Bob Jun 8 '19 at 16:43
  • From there it's useful to know that many typical touchscreen drivers include both a config file (plain text) and a firmware file (presumably loaded into the hardware somehow?) that you'll need ... that would have been on the original image that's now gone :( Short of finding someone else with the exact same device, I can probably grab a few files from a Silead device I have here, but it's impossible to tell in advance whether that would work for you - at a minimum, it'll probably need some tweaking, since I recall some resolution-dependent parameters in there. – Bob Jun 8 '19 at 16:44
  • the screen itself has a model number of LC133LF4L01 which is according to panellook.com is made by a company called Panda. There is a tab on that page labelled touch panel and only one comes up; "13.3inch G/G Capacitive Touch Panel USB&IIC Interface, 2.57mm depth, 7'olock cable" made by ZHUIXI with a model number: 1332W-2507 but there isn't really any other info online about it and unfortunately I don't know Chinese so dare say attempting to contact them directly is out of the question, plus I guess Kogan could have use a different touch device in their design... – Julian Jun 8 '19 at 18:39
  • Further, the id in device manager list the currently unknown device's 'hardware id' (as I've uninstalled the driver for now as doesn't work properly anyway) as ACPI\VEN_MSSL&DEV_1680.. don't know if any of that helps – Julian Jun 8 '19 at 18:46
1

There appears to be a SileadTouch driver embedded in the image you can download from Kogan.

https://help.kogan.com/hc/en-us/articles/360011167753-Kogan-Atlas-Go-S300-KALAP13S300VA-Manual

Bottom of the page, there is a link under "Reinstalling Windows" which points here https://kogan-prod-assets.s3.amazonaws.com/files/support_files/KALAP13S300VA/HQ-JX-13.3-SF133GR210-GA54D-049-C.zip

The driver is located in the following folder:

HQ-JX-13.3-SF133GR210-GA54D-049-C.zip\HQ-JX-13.3-SF133GR210-GA54D-049-C\­®Ã┌049░─┤¾└¹ÐÃËóË´_RS4home64_4100_nooffice_9461_20181116\images\backup\UpdateDriver

The weird folder names are there by default.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.