0

What happened is this: Basically, I was running Windows 10 on Acer Predator G9-791 and I sort of played around in BIOS.

When I have changed the boot mode from UEFI to Legacy and restarted the laptop, I could only see a somewhat smaller logo on boot that says "(Acer Predator image) Predator", but nothing happens after that.

That would not be a problem if I could just switch the boot mode back to UEFI, the problem is, that after this change to Legacy I can no longer access BIOS with F2, I tried using different keys (del, esc, f1-12) but that didn't work either, please help, what should I do?

EDIT: When I removed SSD with windows, it booted to some sort of terminal or something and it keeps saying:

Intel UNDI, PXE-2.0 (build 083) Copyright (C) 1997-2000 Intel Corporation.

For Qualcomm Athernos PCIE Ethernet Controller v2.1.1.5(03/15/13).

Check the connection! PXE-M0F: Exiting PXE ROM. No bootable

device -- insert boot disk and press any key


TL;DR: I can't access BIOS anymore after setting my boot system to legacy

  • 2
    You ahould edit your question instead of adding information as a comment – PiedPiper Jun 8 '19 at 13:35
2

This is how I have managed to solve this:

  • Remove the SSD/HDD that contains Windows10 boot (or any other boot drive)
  • Start the PC and instantly spam F2 key (or whatever is the key to access your BIOS)
  • You should now be able to see BIOS.
  • In BIOS, Change the boot system back to UEFI (in case the option is no longer there, restore the factory settings of BIOS)
  • Shut down PC
  • Connect the boot drive
  • The PC should now be booted into Windows (or any other OS)

Although, I still do not really know, why I wasn't able to access the BIOS instantly without removing the SSD, but this solution has worked for me

| improve this answer | |
  • This solution did not work for me, as the BIOS was still unreachable without the HDD. – Romain Nov 14 '19 at 15:38
-1

I had the same issue with a Lenovo B590. Apparently the keyboard was not handled in legacy mode, making it impossible to reach the BIOS setup menu by pressing F2.

I reset the BIOS in order to set the default configuration again, in which the boot mode was set to UEFI. I was then able to reach the BIOS setup. It can be done in several ways - more info about that here : https://www.wikihow.com/Reset-Your-BIOS

Note : An answer suggested removing the hard drive. It did not allow me to reach BIOS setup.

| improve this answer | |
-1

I found that if you just HOLD the F2 key instead of pressing in when in legacy mode it goes to BOIS instead of Boot manager.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.