2

I am attempting to mount my NAS on my Arch machine and receiving the below error:

mount error(2): No such file or directory
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

Not seeing anything in man which helps.

Below is command I am using

sudo mount -t cifs -o user=<user> //192.168.0.14/volume1/NetBackup/Share /mnt/NAS

I can ping the IP of the NAS. The below command:

smbclient -U <user> -L 192.168.0.14

returns the below:

    Sharename       Type      Comment
    ---------       ----      -------
    NetBackup       Disk      System default shared folder
    photo           Disk      System default shared folder
    surveillance    Disk      System default shared folder
    video           Disk      System default shared folder
    IPC$            IPC       IPC Service ()
Reconnecting with SMB1 for workgroup listing.

    Server               Comment
    ---------            -------

    Workgroup            Master
    --------- 

Right clicking the directory on the NAS displays the path as being:

/volume1/NetBackup/Share

Any ideas on what to do next to troubleshoot?

2
  • Sometimes on my computer I cannot even see directories with my shell (bash) because I’m not in a root shell. It may differ for you, and this possibly cannot work but try changing the parameter user to user=root rather than <user>.
    – user962725
    Jun 8, 2019 at 19:54
  • No that didn't work. There is no root user on the NAS so I wouldn't expect it to. I tried admin too, and that didn't work either. Thanks for suggestion.
    – ZR_
    Jun 9, 2019 at 7:18

3 Answers 3

2

The syntax might be confusing -- after the server name, you don't specify the path, but the share name, as defined in the smb.conf file at the server side. So, instead:

sudo mount -t cifs -o user=<user> //192.168.0.14/volume1/NetBackup/Share /mnt/NAS

use:

sudo mount -t cifs -o user=<user> //192.168.0.14/<SHARENAME> /mnt/NAS
0

I had the same issue it turned out that I forgot to create the share directory so I created the share in the path and voila the error got fixed just I thought to add it as one of the possible cause of the error in case someone may benefit from it

-2

ERROR [root@samba-client ~]# mount -t cifs -o user=smbuser //192.168.20.115/smbshare /client/ Password for smbuser@//192.168.20.115/smbshare: ******** mount error(2): No such file or directory Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) [root@samba-client ~]# mount -t cifs //192.168.20.115/smbshare /client/ -o user=smbuser

Troubleshooting mount -t cifs //192.168.20.115/smbshare /client/ -o user=smbuser

check your samba server configuration file: vi /etc/samba/smb.conf make sure the samba directory name in the square bracket is the same with the one you trying to access from the client end also ensure the path is correct. ie

[smbshare]

    comment = Samba share
    path = /smbshare
    writable = yes
    guest ok = yes
    guest only = yes
    public = yes

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.