1

My work laptop for some reason came with the US English and Swedish keyboard input methods by default (I later added Czech since I needed it) Something causes it to keep switching to the Swedish layout, and I've no idea what that is. I want to remove Swedish altogether, I only need the US and Czech layouts.

This is harder than it seems, because I cannot see any reference to the Swedish layout anywhere in the settings panel. Below are the places I've checked.

The language switching panel shows the Swedish layout under the "English (United States)" option.

The language switching option

There's no reference to Swedish under the "Region & language" options:

enter image description here

Just in case it's not clear - Swedish isn't selectable under "Windows display language".

enter image description here

And underneath the "English" display language on that same page, Swedish isn't mentioned at all.

enter image description here

I cannot find any mention this Swedish input method anywhere in Control Panel or Settings. Does anyone have any idea at all where this can be removed?

0

Hm, that's pretty odd. Silly as it may sound, have you considered installing the Swedish language and then uninstalling it? Maybe part of it got installed somewhere along the line? Might work, if not I have some other suggestions.

0

OK I found a workaround to mitigate this somewhat, but I never figured out how to excise the Swedish input method. What I've done is prevent the "random" switching between the input methods - which was being triggered by a keyboard combination that happened to occur when I was coding (it was Ctrl + Shift, or something like that).

Left-click the language switcher in task tray, select "Language preferences", then in the next window click "Region & language", then "Advanced keyboard settings" then "Language bar options". This will bring up an older-style Windows settings dialog called "Text Services and Input Languages" with two tabs - switch to the "Advanced Key Settings" tab. There will be a table that allows you to enter a key sequence to perform different actions. Hit "Change key sequence" on all of them and select "Not assigned".

Hope this helps anyone else in this situation!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.