How do I get an external 2.5" IDE hard drive in an external case (with USB cable) working when plugged into a PCMCIA USB card?

My hard drive doesn't work when plugged into my HT-Link Cardbus/PCMCIA USB 2.0 2-port card (NEC / 32-bit). My MP3 player will work fine when plugged into it. I tried plugging in both of the USB cables that are on one end (Y cable), and it doesn't make a difference. I read the problem may be insufficient power.


I read the problem may be insufficient power.

I'm assuming your 2.5" drive doesn't have an external power supply? If that's the case, your drive is relying on the PCMCIA USB port for data and power. Your PCMCIA card is to blame here, because it's not providing power to your drive.

Possible solutions:

  1. You mentioned you have a Y-cable for USB. Plug one of those into your PCMCIA card and the other into any USB charger (like the iPod charger). That'll give your drive the power it needs.

  2. Get a powered USB hub. Set it up like so: HDD --> USB hub --> PCMCIA card


I had the same problem with my PCMCIA USB 2.0 card and my external 2,5" hard disk drive (HDD).

The HDD is not detected when: both USB plugs from the HDD's Y-cable are in USB 2.0 ports of the PCMCIA card.

It works fine when: one of the HDD's USB male plugs (the "data" one) is in the PCMCIA card and the other (the power "dummy") is in the laptop's original USB 1 port, for extra current.


I have seen this where the drive needs more power than the USB port supplies. Is it a 2.5" drive? If so, some have a second USB cable (or just a connector) that is plugged in to a second USB port for more power. Some others have an AC adapter.

  • The cable has two USB connectors on one end. I tried plugging both of them into the PCMCIA card.
    – Carl
    May 19 '10 at 17:37
  • Have you tried the drive on a different port or computer?
    – Dave M
    May 19 '10 at 17:40
  • The drive works on my main USB port - but that port only works as a USB 1.1 port now - the 2.0 functionality is broken for some reason - using that hard drive with 1.1 is very, very slow. The drive also works in a USB 2.0 port on another computer.
    – Carl
    May 19 '10 at 18:18
  • What is the make of card you have? I had a real issue with an Adaptec Firewire/USB2.0 combo card. Never could get drives to work. Finnaly gave up and assumed it was the card. Also had a comment from a drive case maker that some larger drives need an AC adapter. Maybe just theirs but something else to consider.
    – Dave M
    May 19 '10 at 18:38
  • It's an HT-Link. Here are the specs: ht-link.com/en/ProductView.asp?ID=106. The card has a power plug input in the middle, but it didn't come with a cable for that. The hard disk is a 2.5" from a laptop. The USB adapter for the hard drive doesn't have a power input.
    – Carl
    May 19 '10 at 21:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.