-3

I installed long time ago "Easy Context Menu" and added when i press right click, the option to "take ownership" from a folder/disk.

Also long time ago I had plugged in my old C:/ HDD from my old system, just to read some files, never had problems.

Then one day, I randomly looked into the HDD without a big reason, and one folder didn't open, and i took ownership.

After restart, when I tried to download from FF but it didn't let me and said something like no enough permission. When pressing windows start menu, a banner pops up where he wants to logout to fix startmenu but after logout nothing changed.

I made a new admin user and another user which i wanted to maybe change to.

I was stupid enough trying to fix after midnight, und i guess i fucked it up.

I have once run "takeown /S system /U username /P password /F "C:/" ", after restart, firefox doesn't open anymore.

Then I tried reseting permissions with "ICACLS * /T /Q /C /RESET", now start menu firefox opens but all letters are kinda gone, at leat at every windows program and edge doesn't open, FirFox seem to work. But all Windows application have only few icons left nothing else.

I read afterwards with reset the he might not know which user owns what.

When I run icacls reset again after, I deleted 2nd User and Admin, then it is technically like before only my original user left. So after deleting all other users it should be more clear that he owns everything what is possible to own as normal user, and everything higher maybe for administrator or UAC style, meaning no own admin account only elevating kinda standard user for several tasks to admin?

  • Bravo, you have successfully destroyed the Windows permissions on the system disk. You will now need to repair Windows. – harrymc Jun 11 at 19:45
  • wow, how useless is your summery? don't you have better things to do with your life and time? if you can't help please go and waste your time somewhere else. – TryToHelp Jun 12 at 8:34
  • Well, I gave some good advice for your problem and your behavior is childish. – harrymc Jun 12 at 8:43
  • I know for my self that I messed up permissions. And that I have to fix that... or do you meant with repair windows a specific way/tool/command? – TryToHelp Jun 12 at 9:04
  • I take that as some sort of apology, so added an answer below. – harrymc Jun 12 at 9:55
1

The permissions that you destroyed cannot be restored, since only the TrustedInstaller account can do that.

You will need to do a Repair Install of Windows 10 with an In-place Upgrade, which is done by the TrustedInstaller account that is capable of restoring these permissions,

This will keep your data, apps and most Windows settings. But as this is a serious operation, take serious backups, including, if possible, an image backup of the system disk.

In the future, better avoid taking ownership or changing permissions of Windows folders. Windows is fragile and vulnerable to such acts.

  • Thank you for taking my implicit apology! :) I couldn't find much time, first now and i encountered several other Problems but it seems promising: When i try to repair install windows from booted usb i get this error: "The upgrade option isn't available if you start your computer using installation media. – TryToHelp 2 days ago
  • If a copy of Windows is already installed on this computer and you want to upgrade, remove the installation media and restart your computer. After Windows has started normally, insert the installation media and run Windows Setup." And when I try over Troubelshould -> Command line i get this error: "An unknown command-line option [/auto] was specified." – TryToHelp 2 days ago
  • Follow my link - since you can boot, you can do the repair from inside Windows. – harrymc 2 days ago
  • The problem is i can't see anything sine all windows system letters are missing, and when i start setup.exe I see only a menu bar with close button and _ button. So i can't setup process. I tried also over CMD, i blind copied "setup.exe /auto upgrade. It starts "full screen" setup at least, but i get then the error "An unknown command-line option [/auto] was specified." – TryToHelp yesterday
  • Your system seems to be destroyed and the light repair tools don't work, so time for the heavy stuff. I suggest to save all your data on external disk, then boot from USB, choose Repair, then Troubleshoot, Advanced options, and try the option of System Restore, and if no go then Startup Repair, and if still no go then try Refresh and finally Reset. – harrymc yesterday

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.