0

I have several network interfaces and am setting them up via NetworkManager. When setting method to manually in IPv4 tab the save Button is greyed out as soon as I enter a Gateway into the Gateway row. This only occurs for certain interfaces.

0

Check if the never-default option is set. This option is not mirrored in the GUI afaik although NetworkManager is intended for graphical desktop environments.

You can try adding the gateway via command line tool:

~$ nmcli connection edit nameOfConnection
> goto ipv4
> set gateway
enter 'gateway' value: 192.0.2.1
> save

Now nmcli should complain after validating the entry.

[…] gateway not compatible to »never-default«

Set this option to false and save should work

> set never-default
enter 'never-default' value: false
> save

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.