0

Every time I'm connected to a Wi-Fi, suddenly, it'll say No Internet, secured even if the Wi-Fi is working just fine. That stops me from using anything including offline LAN features like accessing my router's settings.

It goes away after turning off Wi-Fi and turning on again tho it returns after some time. Sometimes it's minutes, other times, it takes hours for the problem to show up again.

How do I fix this so I can use Wi-Fi uninterrupted?

My laptop's Wi-Fi is just fine until I've reinstalled Windows clean.

Device Manager says my driver is up to date and Windows Update doesn't find an update either. I've tried installing and uninstalling the Intel Wireless Proset listed in my laptop's drivers in the Asus's website but it doesn't do anything.

Asus TP510UQ, Windows 10.

The wireless driver currently installed in my laptop is for Realtek 8822BE Wireless LAN 802.11ac PCI-E NIC.

C:\Windows\system32>ipconfig /all

Wireless LAN adapter Wi-Fi:

Connection-specific DNS Suffix  . :
Description . . . . . . . . . . . : Realtek 8822BE Wireless LAN 802.11ac PCI-E NIC
Physical Address. . . . . . . . . : 40-9F-38-89-69-C5
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Site-local IPv6 Address . . . . . : fec0::71dc:533e:3753:80ce%1(Preferred)
Link-local IPv6 Address . . . . . : fe80::71dc:533e:3753:80ce%7(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.254.104(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : Wednesday, June 12, 2019 6:47:28 PM
Lease Expires . . . . . . . . . . : Thursday, June 13, 2019 7:18:36 PM
Default Gateway . . . . . . . . . : 192.168.254.254
DHCP Server . . . . . . . . . . . : 192.168.254.254
DHCPv6 IAID . . . . . . . . . . . : 88121144
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-24-84-4A-D2-40-9F-38-89-69-C5
DNS Servers . . . . . . . . . . . : 192.168.254.254
NetBIOS over Tcpip. . . . . . . . : Enabled

Thanks in advance.

Screenshot

  • No internet does not mean no connectivity. You can connect to the wifi but if DNS fails, it will still say no internet. You would want to check your ip configuration and ensure that it is what it is supposed to be. ipconfig /all is the cmd command to see it all. Especially the ip range, gateway and dns servers are important. – LPChip Jun 12 '19 at 11:47
  • Yeah. Windows Troubleshooter says that but Wi-Fi is just fine in other devices. Will DNS problem also cause me to not be able to access offline sites like 192.168.254.254. How do I fix it? I will try ipconfig /all – Hamu XD Jun 12 '19 at 11:50
  • I've run ipconfig /all. I've added the details to the post – Hamu XD Jun 12 '19 at 11:57
  • In case you're trying to use WEP, I have had problems with internet connectivity when using this on Windows 10. I need WEP for some old devices, but I had to switch the main router to WPA for Win10 and buy a WiFi extender to provide WEP. – AFH Jun 12 '19 at 12:07
  • WEP was recently discontinued on Windows 10. If your using WEP and Windows 10 version 1903, that would be reason, your unable to connect to the access point. – Ramhound Jun 12 '19 at 12:31
0

I don't know that this will help with this issue, but it does explain how the Network Connectivity Status Indicator indicator works. https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-vista/cc766017(v=ws.10)

| improve this answer | |
  • OP is using Windows 10 not Windows Vista. – DavidPostill Jun 12 '19 at 13:35
  • The NCSI was introduced with Vista and applies to all later versions of Windows. I haven't seen later documentation from Microsoft. – Ed Palmer Jun 12 '19 at 14:25
  • Please quote the essential parts of the answer from the reference link(s), as the answer can become invalid if the linked page(s) change. – DavidPostill Jun 12 '19 at 17:01
0

Having same issue with same model. Bought 2 of these exact same laptops. One I kept in windows s and the other I opted out. I was able to roll back driver to a previous version on opted out windows. Was not able to roll back as grayed out on Windows s.

seemed to be working better. its been a few days with no drops

my model is f510qa ASUS vivobook

| improve this answer | |
0

For my case it was because of my router's setting and my devices were mismatched.

When that happened, my laptop was connected to the router but it showed No Internet connection. But when I connected my laptop directly to the router using cable, there was Internet connection.

I discovered it was due to the setting on my router, and my laptop, they mismatched. My router had DHCP turned off, therefore it would require me to designate an IP on my laptop manually by going to Network & Internet Settings > Change Adapter Options > Select the WiFi Adapter > Properties > Internet Protocol Version 4 > Use the following IP address.

| improve this answer | |
0

I've fixed my problem. I installed the RTL version of the driver to replace the former and everything's now fine.

| improve this answer | |
-1

Your wireless may be going into power saver and not waking up. You can disable power saver by opening Device Manager, bring up the properties for the wireless adapter, select the Power Management tab, then unchecking Allow the computer to turn off this device.

| improve this answer | |
  • It's already disabled. – Hamu XD Jun 12 '19 at 20:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.