2

Currently, I have Ubuntu installed on Windows 10 as a WSL where I installed python and want to use that as an interpreter in Pycharm on Windows 10. I go to the add interpreter settings and expect to see a WSL option as seen in the JetBrains guide.

As seen here, there is a WSL option, but that option doesn't exist on my screen as seen in this screenshot.

How can I enable this option?

Thanks

2
  • 1
    Make sure "Python WSL Support" and "WSL Support Framework" plugins are enabled in Settings | Plugins | Installed. – Pavel Karateev Jun 17 '19 at 11:14
  • Did you figure out how to enable wsl option in PyCharm? – user48115 Jul 8 '20 at 4:12
1

Remote Python interpreters ( SSH, Vagrant, WSL (only for Windows)).

Supported only in PyCharm Professional. <<---here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.