0

I have a passed down mac which had previously installed mySQL. I tried running the SQL server from preferences but it wont start. Uninstallation wont work either. I ran the command sudo /usr/local/mysql/support-files/mysql.server start. It resulted in the following error.

Starting MySQL ./usr/local/mysql/bin/mysqld_safe: line 199: 6557 Trace/BPT trap: 5 env MYSQLD_PARENT_PID=6140 nohup /usr/local/mysql/bin/mysqld --basedir=/usr/local/mysql --datadir=/Applications/XAMPP/xamppfiles/var/mysql --plugin-dir=/usr/local/mysql/lib/plugin --user=mysql --log-error=APS-16.local.err --pid-file=/var/run/mysqld/mysqld.pid --socket=/var/lib/mysql/mysql.sock --port=3306 < /dev/null > /dev/null 2>&1 ERROR! The server quit without updating PID file (/var/run/mysqld/mysqld.pid).

I have uninstalled mySql forcefully and reinstalled. The error is still persistent.
Commands used to uninstall.

sudo rm /usr/local/mysql
sudo rm -rf  /usr/local/mysql*
sudo rm -rf /Library/StartupItems/MySQLCOM
sudo rm -rf /Library/PreferencePanes/My*
sudo rm -rf ~/Library/PreferencePanes/My*
sudo rm -rf /Library/Receipts/mysql*
sudo rm -rf /Library/Receipts/MySQL*
sudo rm -rf /private/var/db/receipts/*mysql*
0

Run the essence of that command manually:

/usr/local/mysql/bin/mysqld --basedir=/usr/local/mysql --datadir=/Applications/XAMPP/xamppfiles/var/mysql --plugin-dir=/usr/local/mysql/lib/plugin --user=mysql --log-error=APS-16.local.err --pid-file=/var/run/mysqld/mysqld.pid --socket=/var/lib/mysql/mysql.sock --port=3306

The way it's running now, the STDOUT and STDERR are being sent to /dev/null so you can see any of the output or errors!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.