0

I've uploaded a VHD image to blob storage and create a image from that and create VM from that successfully. But when creating new VM in Operating System Disk Image my image is not showing. I tried to add market place by,

 Add-AzureRMGalleryItem -SubscriptionId (Get-AzureRmSubscription -SubscriptionName 'my subscription').SubscriptionId -GalleryItemUri https://ubuntuimage.blob.myurl/UbuntuImage.SimpleVMTemplate.16.4.0.azpkg -Apiversion "2015-04-01" –Verbose

When i run above code got below error. But i've installed Azure Stack tools for power shell already,

Add-AzureRMGalleryItem : The term 'Add-AzureRMGalleryItem' is not recognized as the name of a cmdlet, function, script file, or operable program. 
Check the spelling of the name, or if a path was included, verify that the path is correct and try again.
At line:1 char:1
+ Add-AzureRMGalleryItem -SubscriptionId (Get-AzureRmSubscription -Subs ...
+ ~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : ObjectNotFound: (Add-AzureRMGalleryItem:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException

I'm new to the azure. Please suggest me how to add image to Azure Stack market place?

0

You could use Add-AzsGalleryItem from module "Azs.Gallery.Admin".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.