0

How to upgrade to Windows 10 1903 with Users and OS on different drives?

I'm currently on Windows 10 1803 and I would like to update to 1903.

I have an Ausus FX503VD which has a 128GB M.2 SSD and 1TB HDD. I initially installed Windows 10 on the SSD (C:) and changed the Program Files and Users path to point to the HDD (D:). I did this because I migrated from a single drive PC whose Users directory was well larger than 128GB. So I though I could separate the operating system and other files and also take advantage of the SSD for faster startup while at it.

I was able to update to 1803 without a problem but now when I attempt to update to 1903, I get the following screen:

enter image description here

The languages are all the same: en-US.

It's obvious it's because of this change, yet I have been using this PC for a long time now that if I changed the Users path back to point to the C: drive some programs might break and I don't know which ones.

By the way, for the Programs Files directories, I simply created symbolic links from C:\ to D:. I couldn't do that for the Users directory because when I installed Windows on C:\ it created the default Users folder there.

Is there a way to force the update without losing my settings and files rather do an upgrade? And in the even that I do change the settings back, would I break access the Program Files and USers on D:\ due to incompatibility issues?

0
1

I was able to upgrade without losing any changes. Here's my detailed solution in order:

  • In Windows Registry, I changed the Program Files directory back to point to C:\ drive on the M.2 SSD where Windows was installed.
  • I mounted the ISO and did an in-place upgrade. I only had to unistall one program because it was reported not to be compatible with version 1903. After that I updated successfully.
  • I manually compared and copied the newly installed Program Files/(x86) to the current program files on the HDD. Some files were the same others were not.
  • Back in the Registry, I changed the paths back to point to the HDD
  • I booted in recovery mode by holding Shift and selecting Restart under Power button menu.
  • In recovery mode, I renamed/backed up C:\Program Files to C:\Program Files.1903.bak and C:\Program Files (x86) to C:\Program Files (x86).1903.bak in case I needed to go back.
  • Then I created the following symbolic links:
mklink /D "C:\Program Files" "D:\Program Files"
mklink /D "C:\Program Files (x86)" "D:\Program Files (x86)"

And the results (redacted some) of DIR C:\

06/18/2019  11:57    <SYMLINKD>     Program Files [D:\Program Files]
06/18/2019  11:59    <SYMLINKD>     Program Files (x86) [D:\Program Files (x86)]
06/18/2019  11:51    <DIR>          Program Files (x86).1903.bak
06/18/2019  11:51    <DIR>          Program Files.1903.bak
  • After rebooting the PC, all programs and settings behaved the same like before.

Also, not sure whether this is relevant but I did the installation under the user profile that's on the same drive as Windows, since it's the same profile that was used to initially install Windows.

UPDATE

It's critical that you note the permissions on the C:\Program Files and C:\Program Files (x86), specifically for the user ALL APPLICATION PACKAGES otherwise Windows apps will not work.

So, before moving/deleting the folders, make sure the destination folders have the same permissions as the source folders. You might want to do this before changing the paths in the Windows Registry because once Windows reboots, the new directories will be marked as read-only and the only way to modify some of them would be to log in as an Administrator or alternatively reboot into recovery mode.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.