1

I have some uncompressed WAV files that I wan't to compress to a CBR of 8kb/s - which the documentation says is possible by using -b:a 8k in the ffmpeg command.

however when I run it on my raw audio it compresses only as far as 32kb/s and I get this in the output:

Output #0, mp3, to 'MP3_CBR8__D__48__2019_2_26_T=0940.mp3':
  Metadata:
    comment         : Recorded at 01:40:06 26/02/2019 (UTC) by AudioMoth 0FE081F80FE081F0 at gain setting 2 while battery state was 4.3V
    TSSE            : Lavf58.20.100
    Stream #0:0: Audio: mp3 (libmp3lame), 48000 Hz, mono, s16p, 8 kb/s
    Metadata:
      encoder         : Lavc58.35.100 libmp3lame
size=    4688kB time=00:20:00.00 bitrate=  32.0kbits/s speed=69.9x
video:0kB audio:4688kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead: 0.007729%

I'm quite new to using libmp3lame but the line starting Stream #0:0 contains the information that it's meant to be at 8kb/s however in the next couple lines it says bitrate=32.0kbits/s

Basically I'm wondering where I'm going wrong and what I can do to get the compression I want?

(Note: I've used this method to reduce quality to 256kb/s, 128kb/s, 64kb/s and 32kb/s I just run in to errors when I try to go lower.)

Thanks in advance for any help you can offer!

1
  • 1
    For such low bitrates Opus would be a much better choice if it is an option for you.
    – llogan
    Jun 17, 2019 at 22:03

1 Answer 1

3

MP3 was originally specified as MPEG-1 Layer 3, and it supports sampling rates of 32000, 44100 and 48000 Hz. For these frequencies, minimum legal bitrate is 32 kbps.

Support for lower sampling rates and bitrates was added in MPEG-2. To set 8 kbps, your sampling rate has to be one of 22050, 24000, 16000, 11025, 12000, 8000 Hz.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.