I have an HP Probook 4420s (yeah it is ancient). I recently replaced its internal HDD with an SSD and its DVD drive with an HDD in a caddy. It was functioning well no problems there. I had disabled its optical drive bay temporarily since the HDD in the caddy already had an installation of Windows and I did not want it to interfere with the new installation. I dual installed Windows 10 and a Linux distro (Manjaro to be specific) on the SSD with GUID partitioning running on UEFI. Now I want to enable the optical drive again, but was unable to do so. I realized that the BIOS was not saving the settings anymore. I tried to change various settings, even tried the reset option, but to no avail. I might as well add that trying to set an administrator password on the BIOS works.

Is there a way to diagnose if my BIOS is working (reading/writing) properly?

Update: I tried changing the battery, but it still isn't working.

  • This likely is an indication the CMOS battery should be changed
    – Ramhound
    Jun 18, 2019 at 12:34
  • @Ramhound, just a doubt, if so, should not the BIOS reset to defaults instead of keeping the changed values? Jun 18, 2019 at 12:38
  • Are you sure that hasn’t happened?
    – Ramhound
    Jun 18, 2019 at 12:46
  • shouldn’t the coin cell be just for backup power and not a dependency for even temporary writes? the. Your should get notified when the date is wrong on power up. Jun 18, 2019 at 12:48
  • So are you working with UEFI or BIOS? Do you have secure boot?
    – Seth
    Jun 18, 2019 at 12:56

1 Answer 1


I'm thinking CMOS battery as well, since it's an ancient machine. There's always the possibility that there's enough battery power to hold your current settings but not write changes, or something esoteric going on, and batteries are cheap, so give it a try.

  • Yeah I will try this later. Don't have the screwdriver set with me right now. Jun 18, 2019 at 13:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .