1

Every time I reboot Windows 10 the registry setting

HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\OneDrive

Is reset by windows 10 to value

DisableFileSyncNGSC = DWORD:1

Which means that OneDrive does not run until I manually change the Registry DWORD setting back to zero.

Is there a way to permanently set this Registry value to zero so OneDrive runs without intervention?

  • Is this machine connected to an Active Directory domain by chance? – Ramhound Jun 18 '19 at 14:31
  • Is Group Policy setting the regkey back? – spikey_richie Jun 18 '19 at 14:43
  • Hi. This is a home machine that is not part of a Windows domain. – Clive Long Jun 18 '19 at 15:09
  • I bet you guys are on the right path. Try running "GPEDIT.MSC", navigate to Computer Configuration | Administrative Templates | Windows Components | OneDrive, Then check out the settings.. specifically "Prevent the usage of OneDrive for file storage" – Señor CMasMas Jun 18 '19 at 15:48
  • @Senor CMasMas . Gpedit.msc fixed the problem. Can you post as an answer and I will accept it? – Clive Long Jun 18 '19 at 19:36
0

Try running "GPEDIT.MSC"

First, navigate to:

Computer Configuration | Administrative Templates | Windows Components | OneDrive

Then check out the settings.. specifically:

  • Prevent the usage of OneDrive for file storage

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.