3

Windows 10 has this dialog for IPv6:

WIndows IPv6 COnfig dialog

I do not want to autoconfigure DNS servers via IPv6 (The DNS servers obtained via IPv4 are sufficient, and the DNS servers the router from my ISP sends via DHCPv6 are semi broken).

However just selecting "Use the following DNS server addresses" and leaving them blank does not work. After clicking Ok and entering the same dialog, the setting has just jumped back to "Obtain DNS server addresses automatically"

Is there anyway I can disable obtaining DNS addresses via IPv6, but still auto-configure an IPv6 address ?

  • have you tried entering the IPv6 address(es) for the DNS server(s)? I believe that's what that input box is looking for. – mael' Jun 18 '19 at 21:22
  • @mael' I do have any IPv6 DNS servers that I can or want to enter there. I do not want to use any IPv6 DNS servers. – nos Jun 18 '19 at 21:32
  • From my limited understanding: a device with an IPv6 address will attempt to send packets via IPv6 and the router's IPv6 address; if it cannot resolve to an IPv6 address (via a DNS configured with IPv6) it won't use it. It sounds like you're better off just disabling it entirely if you don't want to set an IPv6 address on your DNS - most publicly used DNS include an IPv6 path. – mael' Jun 18 '19 at 22:52
  • 1
    @mael' DNS servers on IPv4 are perfectly capable of serving AAAA records. There is no correspondence there. OP: Just put in Google's DNS servers or whatever other DNS and have done with it. – Michael Hampton Jun 19 '19 at 5:26
  • @MichaelHampton Are you saying there is no way to get DNS servers dynamically ONLY from the IPv4 connection ? The choice I have is to either a) disable IPv6 alltogether or b) hardcode a DNS server ? – nos Jun 19 '19 at 8:34
2

Seems to me that filling the Preferred DNS Server field with something is required. I suggest:

Preferred DNS Server - ::1,
Alternate DNS Server - blank

DNSv6 will fail immediately and auto fallback to DNSv4.

| improve this answer | |
  • While this works for general use, it make makes nslookup fail as it will try to only use the ::1 address. – chutz Apr 3 at 11:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.