1

I installed Urxvt on Ubuntu 18.04 to test it and when I opened Vim I saw the weird colors on the left, when it should be as shown on the right:
Vim Weird Colors   Vim Okay Colors

I tried to change the color scheme, I set the t_Co=256, my $TERM is xterm-256color, in .Xresources the termName is xterm-256color, everything I changed and nothing happened, this weird thing is still here.

Xterm uses the same config file, and in Xterm everything is normal. Currently I use Terminator, but I want to use Urxvt, but I need to solve this. I read about the lack of true color support that Urxvt has, but I don't if this is the case because other YouTubers use Urxt with normal color schemes in Vim.

4
  • Did you logout and login again after every change? Jun 19, 2019 at 3:08
  • 1
    Yes I did, but it didn't solve either. Jun 19, 2019 at 11:33
  • "my $TERM is xterm-256color" – I'm not sure if it's a wise choice. Have you tried urxvt's default, that is, rxvt-unicode-256color?
    – egmont
    Jun 19, 2019 at 13:53
  • Yes, I tried... Nothing yet. Jun 19, 2019 at 17:22

2 Answers 2

1

tldr: Workaround - set term to 88 color mode.

I've also had issues like this. I found that urxvt as provided in centos(7, and 8-stream) only supports 88 color mode. It even provides the symlink /usr/bin/urxvt256c -> urxvt. But doesn't actually work for me for 256 colors.

256colors2.pl shows a few random colors in the index above 88, but mostly black. Otherwise only system colors and the first 2 6x6 color cubes look OK. I instead set my TERM to xterm-88color to match the actual capability. VIM looking OK again, and color themes look better. Jellybeans is has been my go to theme.

After - corrected colors urxvt.termName: xterm-88color urxvt256c.termName: xterm-256color

I tried to compile urxvt from source to enable that option, but the configure script seems to ignore most specified options. I gave up on trying to get that to work.

Hmm.. I wonder if I can manually set the other colors?

0

Not an expert, but I've had similar issues setting up urxvt/vim. I fixed it with the setting set notermguicolors and set background=dark in vim, though the latter might not be necessary in your case.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .