6

I am consistently getting the following error with VSCode for Mac when using pipenv:

Workspace contains Pipfile but 'pipenv' was not found. Make sure 'pipenv' is on the PATH.

Running "which pipenv" gives a location (/usr/local/bin) that is in my PATH when I echo $PATH.

5

I solved this issue by providing an absolute path to my pipenv binary for the vscode setting python.pipenvPath. The default setting of "pipenv" does not appear to work, despite pipenv being part of my PATH and working just fine outside of vs code.

  • Setting python.pipenvPath in Workspace settings (not User settings) resolved this longstanding issue. Thanks! – nik Aug 21 '19 at 11:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.