1

I have an external drive in HFS+ format. However, the disk could not be mounted (i.e. not shown up in Finder) to my Mac (v10.14). Here are the diskutil result and what I tried.

> diskutil list
/dev/disk0 (internal):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                         500.3 GB   disk0
   1:                        EFI EFI                     314.6 MB   disk0s1
   2:                 Apple_APFS Container disk1         500.0 GB   disk0s2

/dev/disk1 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +500.0 GB   disk1
                                 Physical Store disk0s2
   1:                APFS Volume Macintosh HD            477.1 GB   disk1s1
   2:                APFS Volume Preboot                 44.3 MB    disk1s2
   3:                APFS Volume Recovery                509.8 MB   disk1s3
   4:                APFS Volume VM                      4.3 GB     disk1s4

/dev/disk2 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:     Apple_partition_scheme                        +24.3 MB    disk2
   1:        Apple_partition_map                         32.3 KB    disk2s1
   2:                  Apple_HFS Flash Player            24.2 MB    disk2s2

/dev/disk3 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk3
   1:                        EFI EFI                     209.7 MB   disk3s1
   2:                  Apple_HFS My_Drive                999.8 GB   disk3s2

I tried sudo diskutil mount /dev/disk3s2 and got Volume on disk3s2 timed out waiting to mount. Does anyone know what happened and/or how I could get it fixed?

1
  • Did you try using Disk Utility to do a First Aid scan on both your disk itself (to check the GPT) as well as the HFS+ partition?
    – Spiff
    Jun 19 '19 at 23:06
0

Is your unmounted drive listed in Disk Utility as greyed out? If yes, then select the drive and press the Mount button. If this doesn't work then try a different cable connection or plug it to another Mac system.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.