1

When trying to install or update packages, I got the following error:

dpkg: error processing package libssl1.1:amd64 (--configure):

installed libssl1.1:amd64 package post-installation script subprocess returned error exit status 10

Errors occurred while processing the following packets: libssl1.1:amd64

E: Sub-process /usr/bin/dpkg returned an error code (1)

I did:

sudo dpkg --configure -a

sudo apt-get install -f

Do I need reinstall dpkg?

2

I was stucked in the same problem. I tried this and worked to me:

cd /var/lib/dpkg/info
sudo rm libssl1.1:amd64.postinst libssl1.1:amd64.shlibs libssl1.1:amd64.postrm
sudo apt update && sudo apt upgrade

got from linuxquestions.org forum.

  • This helped, thank you very much. – Alex Jun 20 at 10:17
  • Hey it worked !! Thanks dude – dctremblay Jun 23 at 19:54
  • Worked on Ubuntu Server 18.04, thanks! – Skylar Ittner Jun 26 at 19:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.