0

Currently I'm noticing a horrible performance when I put my VM's on my internal HDD. The HDD is split into 3 Partitions (D:, E:, F:) and have a maxiumum capacity of 500GB by 7200rpm.

File copy from the M.2 SSD to the HDD and vice versa is pretty fast (around 115 MB/s) but as soon as I start a VM the usage stuck between 98% - 100%. For now I have no idea what is causing the behaviour and I don't know if this is normal.

Further more information about the host system:

  • OS: Windows 10 1809
  • CPU: i5-8250U (yes, it is a laptop)
  • RAM: Single Bank 8GB DDR4 2400MHz
  • SSD: M.2 Samsung EVO860 (256GB)
  • HDD: 500GB 7200rpm (about 8 - 10 years old)
  • Hypervisor: VirualBox

For any idea I would be thankfull.

  • Performance in a HDD is always way worse than SSD. A VM will add to that. – GabrielaGarcia Jun 19 at 20:07
  • What OS are you running in the VM? Are you using Hyper-V or Oracle VirtualBox? How much RAM are you allocating to the VM? It sounds like a paging issue, in that the VM is just paging to disk as it's out of RAM. – spikey_richie Jun 19 at 20:07
  • @spikey_richie Oh crap! Sorry I forgot to name the hypervisor. It is VirtualBox. I only test Win Server 2016 Standard for know. I gave it 2Gb of RAM what was sufficient while running the VM from the SSD. – MarvinMcFly Jun 19 at 20:11
  • 1
    Right, but paging out to the SSD would be OK as it's performant. Paging to a regular HDD is not. What if you allow the VM to use 4GB or RAM? – spikey_richie Jun 19 at 20:12
  • 1
    @spikey_richie Thank you! I have post a answere for all who may have a simillar issue. – MarvinMcFly Jun 20 at 14:54
0

At first, thanks to @spikey_richie! Adapting the VM to 4 GB RAM gave a little performance increase. Further I disabled the SWAP file and the disk usage dropped immediately to 5% - 10% in idle. I guess what also could be a "performace eater" is the dynamically VM disk. Creating a fixed size may increse the performance also.

  • You will unlikely see any increase any performance by using a fixed size virtual HDD. – Ramhound Jun 20 at 17:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.