0

At work they just updated my Windows 7 to Windows 10. VMWare Workstations Pro 14 was installed by them over Windows 7. I had a couple VMs that worked fine.

After the update, VMWare would not start, claiming that a dll was incompatible. The IT admin (ya I know, I am not admin on my work laptop! HAAA!) uninstalled it and installed it again.

Now my MVs do not start anymore. When I try to start a VM that existed before I get:

  • 1st start: Cannot find a valid peer process to connect to.
  • 2nd start: loops for ever on the vmware startup black page, with the rotating square.

I tried creating a brand new VM. It just stays on the VMWare startup page with the square that rotates, for ever. It is stuck so well that I have to reboot. I cannot kill VMWare while it is "looping" like that, since it claims the VM is busy. I left it looping for 2 hours, so I know it is not a "wait it out" issue.

I looked at:

  • console messages in VMWare: nothing
  • events in Windows, nothing
  • reseach into the issue turned out only pages about VMWare Fusion on Mac...
  • Turned on the BIOS setting for virtualization.
  • Made sure Hyper-V does not run.

Any ideas of what I could look into next? My IT department will not help, as they are clueless when it goes beyond a mousepad issue.

VMWare Workstation 14 Pro, 14.1.1 build-7528167, fully licensed.

Thanks!

4
  • VMWare Workstation Pro 14 absolutely works on Windows 10. I am currently running it on my personal machine. It also supports every version of Windows 10 as a guest operating system. Sadly, you have not provided enough information to solve this problem, but I suspect you have a problem that only your IT Administrator can fix. Almost sounds like you have Hyper-V installed but typically you would get an error message indicating that is the case. I would have the Administrator reimage the entire machine after you back up the VMs (both the virtual HDDs and the configuration files).
    – Ramhound
    Jun 19, 2019 at 22:02
  • Makes sense. The problem is I see nothing in logs that I have, and the admin is useless... Time to start thinking outside the box...!
    – Nic3500
    Jun 19, 2019 at 23:16
  • What Windows 10 version (winver.exe)? v1903 breaks compatibility with a number of virtulization products, including VMWare Workstaction 14 (I use it fine with Win 10 v1803). The Windows installer should flag that as an issue if you're on 1903, and VMWare Workstation 15 supposedly fixes the issue.
    – NextInLine
    Sep 3, 2019 at 16:16
  • Older than v1903. I will keep that in mind when IT upgrades our systems...
    – Nic3500
    Sep 3, 2019 at 16:20

2 Answers 2

1

The problem was that the VMWare Authorization Service was not running. I never found why that service sometimes does not start even though it is in Automatic mode.

After a reboot, starting that service, VMWare was working correctly.

In case someone has the same issue...

1
  • Try to start it as delayed automatic. Worked for me.
    – Thinkeye
    Nov 10, 2019 at 21:22
-1

I had the same problem. The problem might be regarding new Windows 10 update. Thanx to the blog post on https://vinfrastructure.it/2019/09/vmware-workstation-issue-cannot-find-a-valid-peer-process-to-connect-to/ and https://www.ghacks.net/2018/12/29/windows-10-user-profile-service-event-id-1534-warnings/ that helped me to resolve the issue.

The main point is to remove the TDL registry entry.

At first go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileNotification\TDL inside the registry editor.

  1. If a TDL key exists, right-click on it and select Export to back it up.
  2. Right-click on TDL and select Permissions from the context menu.
  3. Select Administrators under "Group or user names".
  4. Check "Full Control" under "Permissions for Administrators".
  5. Click on ok.
  6. Delete the entire TDL key afterward.

Then go to HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows NT\CurrentVersion\ProfileNotification

  1. Repeat the TDL exporting, permission adding, and deleting process described above.

    Finally restart the PC.

Some might encounter problem changing permissions. In that case you need to change the ownership first. In my case, the ownership was TrustedInstaller which i changed to Administrators. You can change the ownership in the following way:

  1. Inside Permissions, select Advanced.
  2. Beside owner, click on the change button.
  3. Inside the text area, enter Administrators or whatever user/group you want
  4. Click Check Names
  5. Click OK

This will change the ownership and then you can move on to delete the TDL entry.

1
  • Please quote the essential parts of the answer from the reference link(s), as the answer can become invalid if the linked page(s) change.
    – DavidPostill
    Sep 15, 2019 at 11:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .