0

I am running Debian 9.9 and the system us fully up-to-date and I tried up upgrade LibreOffice this morning, and now it will not start.

If I start it from the desktop, the splash screen comes up and the progress bar moves about 1/3 of the way, then it goes away and nothing happens.

If I start it from the command line with libreoffice6.2 --writer, the same thing happens only the terminal spits out "Application error".

  • I've tried logging into the system with a brand new user, same results.
  • I've checked to make sure there are no LibreOffice processes running.
  • I've done "apt purge LibreOffice*" and verified that anything LibreOffice is removed from the system, rebooted, then installed and rebooted again, same problem.
  • Tried installing the old version again, no good.

I'm at a loss now. It was working this morning, and told me there was a new version available, which is what started all of this.

Any ideas?

  • Just as a test, try installing LO from a download from the LO web site (and check their release notes to ensure all dependencies are met). – fixer1234 Jun 20 at 17:35
  • @fixer1234 That's how I am installing it. The version in the repos is way behind. – DeadTOm Jun 20 at 17:39
  • Then check the dependencies and release notes. Sometimes the versions are behind due to compatibility with other stuff in the distro, like requiring conflicting versions of libraries. If that's the issue, try installing a snap or flatpack version. Those can have other issues, but they are more self-contained and sandboxed. You could also try the Debian backports. Testing or Unstable may contain a relatively current version. – fixer1234 Jun 20 at 17:57
  • @fixer1234 I found nothing helpful in the release notes, and no mention of dependencies. Dpkg doesn't complain about missing dependencies during installation, and "apt install -f" reports that everything is fine. I don't know where else to look for missing dependencies. – DeadTOm Jun 20 at 18:10
  • It's easy to get tied up in your underwear trying to solve these problems. Try the easy solutions first, like the Debian backports or a snap or flatpack installation. – fixer1234 Jun 20 at 18:15
1

I had the same issue with 6.2.4 and it repeats with 6.2.5. The only solution I found out is removal of libreoffice-kde-integration and installation of libreoffice-gnome-integration instead.

There is also a bug report about that: https://bugs.documentfoundation.org/show_bug.cgi?id=126272

Cheers, Pushkin

  • Thanks for posting this; good find. For the OP, though, this may not be the issue because they downloaded directly from LO, and that would not have a specific desktop integration (unless the issue is that gnome integration is required). – fixer1234 Jul 8 at 23:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.