1

In Visual Studio 2017, trying to Python import pandas from an interactive window in an environment called 'scraper2'. I get an error message that I'm missing a required dependency - numpy.

Microsoft Visual Studio 2017 error message]

I was originally working on a Python application and realized that I would like to use Numpy and so tried to add it to that environment (not shown here) called scraper. When I had this same difficulty, I tried creating a new conda env from scratch with just a few packages in it (python, numpy, pandas, jupyter). The conda environment was created with this environment file:

Name: scraper2

Dependencies:

  • python
  • numpy
  • pandas
  • jupyter

Which I created with (I think) this conda prompt command: conda env create -f filename.yml. (this editor doing odd things with my text, the yml file has the dependencies on separate lines)

Investigating this environment (conda activate scraper2) I am able to start Idle and 'import pandas as pd' or 'import numpy' without an error. I can also start a jupyter notebook in this same environment and import pandas without issue.

Idle importing without error in the same environment]

Even in Microsoft Studio 2017, once I switch the interactive window to scraper2, when I begin to type 'import num' the completion text shows 'numpy' as an option with a little package icon (along with another package 'numbers' that I can import without issue). However, if I ">>>import numpy" I get that the DLL Failed, module not available message as in the first image.

Even more confusing (to me), when I'm in the Visual Studio 2017 scraper2 environment interactive window and use 'help()' and 'modules' the help module clearly shows both pandas and numpy as available, as seen in the last pic.

Microsoft Visual Studio 2017 showing numpy available as a module]

I'm new to Visual Studio 2017 and am clearly doing something wrong that I can't figure out. Any advice that can be offered will be appreciated.

0

You must log in to answer this question.

Browse other questions tagged .