2

My system language is English, but I have set Czechia as a Language for non-Unicode programs and Region formats because some applications didn't work for me - didn't show the special characters correctly. I also use a Czech keyboard layout.

When I activate the Emoji keyboard pressing "Windows + ." it says "Keep typing to find an emoji" in English but when I type there fxp "cry" it won't find anything. I have to type there in Czech language. Is there any way to change this behavior?

I'm running Windows 10 Pro N / 1809 with latest updates.

  • @Ramhound I understand that it makes sense but I prefer to use English over Czech language and I'd like to change this. And it's not Keyboard layout related, because on my second PC I have the exact same settings - English display language and Czech keyboard and the Emoji keyboard typing language is English. – sczdavos Jun 20 '19 at 21:51
  • The second pc is running Windows 10 Home. Version should be the same with latest updates . – sczdavos Jun 21 '19 at 3:42
  • I do. I'm watching Netflix on MS Edge and it's not working without Media pack installed. So when any bigger update removes it for me I have to reinstall it manually. How's Media pack related to the Emoji keyboard? – sczdavos Jun 21 '19 at 13:16
  • 1
    It might not actually be related. I am asking questions and more information that might be relevant, so your question has a chance of being answered. I won’t be able to help you at this point.. I hope you figure it out. All possible relevant information should be in the question body. – Ramhound Jun 21 '19 at 13:35
3

A picture is worth a thousand words:

Emoji example

Above examples snipped from emoji picker started using Win + . i.e. Windows logo key + . (period) during text entry

Tested using the following language settings:

D:\PShell\_test_Get-Culture.ps1
Language     LangTag KbdID    KbdLayout                  
--------     ------- -----    ---------                  
English      en-GB   00000405 Czech                      
English      en-GB   00000452 United Kingdom Extended    
Czech        cs      00000405 Czech                      
Czech        cs      00020409 United States-International

The _test_Get-Culture.ps1 script:

### _test_Get-Culture.ps1 ###
$gcRegKey = 'HKLM:SYSTEM\CurrentControlSet\Control\Keyboard Layouts'
$gcWULL = Get-WinUserLanguageList
$cgWULLHuman = $gcWULL | ForEach-Object {
    $gcU=$_
    $gcUIMT=$gcU.InputMethodTips
    if ( $gcUIMT ) {
        $gcUIMT | ForEach-Object {
            $cLx=$_.Substring(5)
            $cLz=Get-Item -LiteralPath "$gcRegKey\$cLx"
            $cLy=$cLz.GetValue("Layout Text", $gcU.LanguageTag)
            [psCustomObject]@{
                "Language"  = ($gcU.EnglishName).Replace(' (1453-)','');
                'LangTag'   = $gcU.LanguageTag;
                "KbdID"     = $cLx;
                "KbdLayout" = $cLy
            }
        }
    } else {
            [psCustomObject]@{
                "Language"  = ($gcU.EnglishName).Replace(' (1453-)','');
                'LangTag'   = $gcU.LanguageTag;
                "KbdID"     = '';
                "KbdLayout" = 'N/A'
            }
    }
}
$cgWULLHuman
  • Thanks for figuring that out! Just one silly question. What's the difference between input language and input keyboard and where do I set it? – sczdavos Jun 23 '19 at 8:04
  • @sczdavos You can use Set-WinUserLanguageList Powershell cmdlet (unfortunately #requires -RunAsAdministrator), or hand-made in Language Preferences (Start => Edit language and keyboard options). Also read entire thread What's the difference between a “Keyboard Language” and an “Input Language”? – JosefZ Jun 23 '19 at 10:04
  • 1
    Thank you I've resolved it. There's an "Override for default input method" settings. Where I had to set the English - Czech instead of Czech - Czech. – sczdavos Jun 23 '19 at 18:39
  • 1
    A good picture might be worth a few quid, but I have no idea what I'm looking at. – Adam Jagosz Nov 14 '20 at 15:49
  • @AdamJagosz answer updated 😈 – JosefZ Nov 14 '20 at 16:59
0

I added and English entry (keyboard layout + language pack) in Settings > Language > Preferred languages.

I need to switch to that keyboard layout before I can search for emojis in English, but at least it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.