1

I'm using this VM to emulate a 32 bit mips system: https://people.debian.org/~aurel32/qemu/mips

I run the VM with the command: sudo qemu-system-mips64 -M malta -kernel vmlinux-2.6.32-5-5kc-malta -hda debian_squeeze_mips_standard.qcow2 -append "root=/dev/sda1 console=tty0" -net nic,model=virtio -net bridge,br=br0

but when I try to ping my host it says Network is unreachable showing that I have no outside connection. I tried various different methods to tackle this such as creating a bridge interface as recommended per this youtube video: https://www.youtube.com/watch?v=G0NNBloGIvs at 3:59 but still coming up short.

I use a wifi connection with my ifconfig returning this:

wlo1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
    inet 10.138.78.4  netmask 255.255.0.0  broadcast 10.138.255.255
    inet6 fe80::5a59:bec7:6457:797b  prefixlen 64  scopeid 0x20<link>
    ether f8:34:41:fb:4c:58  txqueuelen 1000  (Ethernet)
    RX packets 359086  bytes 466989022 (466.9 MB)
    RX errors 0  dropped 0  overruns 0  frame 0
    TX packets 110602  bytes 19565385 (19.5 MB)
    TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

I highly appreciate any help, thank you!

0

You must log in to answer this question.

Browse other questions tagged .