0

I have installed Anaconda 3 on my computer and it will not open the navigator or let me run any of the programs, such as Jupyter Notebooks or Spyder. When I click on the Navigator app it briefly opens two black screens and then closes and then doesn't do anything. If I try to run it from the command prompt it gives me the following error.

>anaconda-navigator

WARNING: The conda.compat module is deprecated and will be removed in a future release. Traceback (most recent call last): File "C:\Users\micha\Anaconda3\Scripts\anaconda-navigator-script.py", line 10, in sys.exit(main()) File "C:\Users\micha\Anaconda3\lib\site-packages\anaconda_navigator\app\main.py", line 103, in main from anaconda_navigator.app.start import start_app File "C:\Users\micha\Anaconda3\lib\site-packages\anaconda_navigator\app\start.py", line 34, in from anaconda_navigator.widgets.main_window import MainWindow File "C:\Users\micha\Anaconda3\lib\site-packages\anaconda_navigator\widgets\main_window.py", line 37, in from anaconda_navigator.utils.analytics import GATracker File "C:\Users\micha\Anaconda3\lib\site-packages\anaconda_navigator\utils\analytics.py", line 44, in from anaconda_navigator.external.UniversalAnalytics import Tracker File "C:\Users\micha\Anaconda3\lib\site-packages\anaconda_navigator\external\UniversalAnalytics\Tracker.py", line 28, in from six.moves.urllib.request import (HTTPSHandler, Request, build_opener, ImportError: cannot import name 'HTTPSHandler' from 'six.moves.urllib.request' (unknown location)

I have attempted to uninstall and reinstall many times and I attempted to manually install an SSL package because some people suggested this worked for them.

Any help with this matter would be greatly appreciated.

1
  • I have also attempted to update anaconda as well and it does not work because it appears it is not letting the system make external requests. – Michael Huber Jun 22 '19 at 19:26
0

Basically I just had to move some files within anaconda3 installation folder from one path to another.

Navigate to %ANACONDA_HOME%\Library\bin, there you will find the files listed below

libcrypto-1_1-x64.dll libcrypto-1_1-x64.pdb libssl-1_1-x64.dll libssl-1_1-x64.pdb So, just move them to this path: %ANACONDA_HOME%\DLLs

Give it a try one more time and you will be able to run it.

-1

I had the problem today, solved it by doing the following:

pip install pyqt5
1
  • Are you sure that's the way OP has to fix? And are you able to explain why? – 174140 Aug 5 '19 at 11:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.