MsMpEng.exe disk accesses are making my system unusable. Since this process is critical for system security, it is unreasonable to disable it. Moreover, as it is provided by the OS vendor, and people are always complaining about it making their systems unusable, there must be some way tell it to be "nice" about disk accesses so I can get my work done without exposing my system to exploits.

I'm not CPU bound as I've 6 cores and set affinity for MsMpEng.exe to 3 of them. I'm not memory bound. Indexing is not running. I've moved everything I can to SSD. I've disabled scans on large directories that I know are unlikely to harbor exploits.

Something is very wrong about this situation and it isn't that MsMpEng.exe is doing its job. It's just not being nice about it.

So how can I tell the OS to make MsMpEng.exe be nice about disk accesses so I can use my computer while it's running?

  • Have you checked the drive for failures? – shawn Jun 24 '19 at 18:20
  • How would one check the drive for failures? I go into Windows->Events->Errors->Critical and see nothing but noise from 36887 70 whatever that is. – James Bowery Jun 30 '19 at 14:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.