0

I have a Dell Inspiron 7373 13" laptop which is fitted with a 256GB SATA M.2 SSD. The Dell spec for the laptop states that it can use either SATA M.2 SSDs or NVMe M.2 SSDs. So I ordered a Samsung 970 Evo Plus NVMe M.2 500GB SSD.

I used Macrium Reflect 7 to first create a Rescue USB then created an image of my existing 256GB SATA drive. Just to clarify, I made a complete image of all the drive partitions.

I removed the 256GB SATA SSD from the laptop and installed the new 500GB NVMe SSD. I rebooted the laptop using the rescue USB and copied the image onto the new NVMe SSD. This all went perfectly.

Finally I shut down the laptop, removed the rescue USB and restarted the laptop but it would not boot into Windows. I tried a boot repair using Macrium and it reported that all was good but the laptop will still not boot from the new drive. I also tried a Windows boot repair but this also failed to solve the problem.

In the BIOS the new drive is visible and I have checked all the BIOS setting and I cannot see anything that will prevent it booting.

The only thing I can think of is that the boot partition that I cloned from my old SSD does not have the NVMe SSD drivers because previously it was a SATA SSD with the SATA drivers.

I have checked Samsung's website and they have an exe file download for installing the NVMe drivers. So I put back my old SATA SSD into my laptop and booted into windows. I checked the device manager for installed drivers and sure enough there was no NVMe driver installed under disk controllers, only SATA driver. So I tried to install the Samsung NVMe driver before taking another image but it will not install the drivers unless a Samsung NVMe SSD is present.

I am now struck, I cannot install the NVMe driver unless the drive is installed but if I install the drive it will not let me boot into windows to install the driver! One thought was to purchase a NVMe external enclosure so I can connect the NVMe SSD via the USB3.1 port, this may then enable me to install the NVMe drivers before I cone the SATA SSD.

Has anyone had the same problem and solved it or can anyone suggest a work around for this problem? I am starting to lose the will to live!!!!

Thanks.

Steve

  • Sounds silly but are you sure that your partition is set active? Have you tried booting with a Windows 10 installation usb and poking around with diskpart to see what windows can see without drivers. I seriously doubt that you need a driver to boot the new drive.. it is more likely having to do with active partition or master boot record. – Señor CMasMas Jun 24 at 19:20
  • I assume you made a complete image of the first SSD and restored all partitions on the new SSD? Instead of submitting a comment be sure you clarify this point within the question body. – Ramhound Jun 24 at 20:29
  • Thanks for your responses, yes the drive partition is set to active, I have tried booting with the rescue usb but to be honest I am not that confident to start poking around with diskpart. AS you say, it may be the master boot record that is the problem not a missing driver. – Evo5man Jun 25 at 20:36
1

An NVMe drive needs to boot in UEFI mode, and has to be in GPT particioning style.
In order to check these both things, do the following:

  1. Boot up with your old SSD.
  2. Now, we're going to check the UEFI boot. Be aware thet your BIOS has to support UEFI booting, otherwise this would not work.
  3. Press the Windows key + R. Type msinfo32 and press Enter.
  4. Check that next to BIOS mode UEFI is listed. Remember that.
  5. Press the Windows key + R, and write diskmgmt.msc Press Enter.
  6. On the left pane, look for your SSD. If you're unsure which is it, right-click and click propierties on every disk, until you find the one whose name is the one of your old SSD.
  7. On the propierties window, go to the volumes tab, and, check that next to partition style, is listed "GUID Particion Table (GPT)"
  8. Remember if it says that or "Master Boot Record (MBR)".
  9. Install your new NVMe disk, with the already cloned image.
  10. Create a Windows Installation USB Important: Create a USB, not a DVD drive
  11. Boot to that USB in UEFI mode in BIOS (You'll have to enable UEFI in BIOS first. This does depened on BIOS manufacturer)
  12. Skip to step 18 if your disk was already GPT. If not, continue.
  13. Type diskpart
  14. Write list disk
  15. Write sel disk n (n is the number of your NVME disk)
  16. Write convert gptThe operation should convert the disk to GPT.
  17. Write exit
  18. If your BIOS mode was already UEFI, skip to step 20. If not, continue.
  19. Run the following commands:

    diskpart
    list disk
    select disk n (n is the number of your NVME disk)
    list partition
    select partition n (n is the number of the Windows particion. It's ussually the biggest one)
    shrink desired=260
    create partition efi size=260
    format quick fs=fat32
    list partition
    list volume (Note the volume where Windows is installed)
    exit
    bcdboot X:\windows (Replace "X" with the volume letter of the Windows OS partition)

  20. Reboot your PC, and boot from your NVMe drive in UEFI mode. It should work now.
  • Thank you for such a detailed response, I am nervous about using diskpart but with your detailed description I will try this and let you know how I get on. Your help is very much appreciated, I would never have found this solution as I am a novice when it comes to operating systems! – Evo5man Jun 25 at 20:43
  • By the way, the Samsung NVMe driver is not essential for booting up. Windows has NVMe drivers that will take control of the drive and boot it up. – milo8505 Jun 25 at 20:55
1

I can now confirm that the problem I experienced booting my cloned Samsung 970 Evo plus NVMe SSD into Windows is now solved!

I was advised by Macrium to try booting into Windows in safe mode. They thought that loading Windows in safe mode with a minimum drivers, etc may enable Windows to boot far enough to find the new drive and load the NVMe drivers. I tried this and it worked! Once I was in Windows in safe mode I went to Device Manager and sure enough the Windows NVMe driver had been loaded and the drive was present.

I then logged out, shut down and restarted the laptop in standard mode and everything loaded as it should. I have now updated to the Samsung NVMe SSD driver and run some diagnostics and benchmarks. All is running as it should and much faster!

I would like to say a big thank you to all the forum users that took the time and effort to provide a response with help and suggestions to assist me with this problem.

Sometimes the simplest solutions are the ones that you don't think of!

Steve

  • I had the same problem, both drives were GPT UEFI to begin with. The source drive SATA and the destination drive NVMe. Windows 10 crashed on boot. Booting into safe mode once just as you did solved the problem. – Chris Jansson Aug 4 at 9:16
0

I checked the device manager for installed drivers and sure enough there was no NVMe driver installed under disk controllers, only SATA driver.

Device Manager doesn't show installed drivers. Device Manager shows connected devices – you might have 100 different storage drivers installed on the system, but if the only thing currently connected is a SATA AHCI controller, then that's what you will see.

Fortunately, Windows 10 already has generic NVMe drivers built in (along with AHCI drivers, IDE drivers, and all sorts of SCSI drivers – they don't show up in Device Manager either).

The usual problem, whether you're migrating from IDE to AHCI or from AHCI to NVMe, is that the drivers are not configured to start on boot – they must be already present very early during the boot process, before the normal "device detection" system has been started. By default, Windows only boot-starts those drivers which were needed at installation time – the rest are still on the system but only get started "on demand" in a later phase.

The generic Microsoft NVMe driver seems to be called stornvme. (For comparison, the generic SATA AHCI driver is storahci, though Intel RST has a different name.) You can change its configuration using sc from an administrator Command Prompt:

sc set stornvme start= boot
sc query stornvme
sc qc stornvme
  • Thanks Gravity, I will try this solution too along with the detailed solution from milo8505 and let everyone know how I get on. I just hope that I can get it going! – Evo5man Jun 25 at 20:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.