25

Copy-paste functionality stops working after about an hour after each reboot on a Windows 7 64-bit system. Running Google Chrome (with gmail and few other tabs open like Calendar, Reader), MS Outlook (which I don't think has anything to do with the problem — I saw it when outlook was off as well), iTunes (9.1.1.12 if it matters).

Would appreciate hints where and what for to look in a registry, and ideas for possible fix.

That is not an Internet Explorer problem (I don't even run it) — it happens in all applications.

Neither Ctrl-C/Ctrl-V nor context menu right-click Copy-Paste (actually, nothing happens on Copy, so there is nothing in a clipboard to Paste) are working. Drag-and-Drop (where supported) continues working though.

  • 1
    My personal experience with this is that it was a misbehaving application that was causing this. I don't recall now but I think even if the application was closed, the problem persisted and required a reboot. Check what tasks you have scheduled if any (eg, with "Autorun"), what processes you are running (eg, with "Process Explorer"). As drJames mentions below, run an antivirus scan. – Peon May 25 '10 at 22:26
  • Resolved the issue (this and others) by disassembling Windows computer and switching to Mac Mini. :) Why the hell haven't I done that years ago? – earlyadopter Dec 29 '11 at 18:06
  • Do you guys have a RAM cleaner of some sort? Check if it has a "clean clipboard" setting, try removing it then see what happens. – user155860 Sep 2 '12 at 2:30
  • For Windows XP see superuser.com/q/18814/93604, the solution is the same. – Tomas Jul 19 '16 at 13:45
34

A bit late, but hopefully this can still help someone.

I have this exact same problem as well, on Windows 7 64-bit too. For me, I just found out it was caused by Outlook 2007.

You can find out which application is keeping a lock on the clipboard by running David Candy's app: http://windowsxp.mvps.org/temp/GetOpenClipboardWindow.zip

This gives you the PID which has the lock.

  • 2
    Running that program helped me; it said "successfully opened and closed the clipboard", and after that, paste is working again :-) – Plutext May 17 '12 at 2:49
  • I have the same problem and downloaded that software but said everything is fine!!! man copy paste is not working, even if use right pop-menu ! – C graphics Jul 13 '13 at 19:22
  • It is weird that even though it said that everything is fine, it fixed the clipboard for me...I wish I knew which application caused my issue so I could file a complaint, :P. – John Odom Sep 30 '14 at 15:03
  • 1
    Worked great for me. Turns out Notepad++ had the clipboard locked. Possibly because I tried to copy a huge amount of data into it a few minutes ago (300+MB). If the clipboard is locked, it will give you the PID of the locking process. If you can't find that in normal task manager, as per the program's suggestion, open System Information (Start->Run->msinfo32), that has a more complete list of running tasks. It pointed me to Notepad++ and when I went there, NPP was behaving a little strangely (couldn't type in all open files, etc). I closed it and the clipboard freed up. – SSilk Mar 30 '15 at 16:29
  • TeamViewer was the badass for me – Housy Nov 13 '15 at 13:48
4

Got another solution from the Microsoft Forum Thread

The solution worked for me is

Type Go to Start (Start/Run) type the following in the search box: cmd /c “echo off | clip” then hit Enter.

2

Piggie-backing on what SSilk said in his answer, try to turn off Notepad++ if it's open. In my case too, it was interfering with the clipboard on a Windows Server 2012 R2 machine.

Worked great for me. Turns out Notepad++ had the clipboard locked. Possibly because I tried to copy a huge amount of data into it a few minutes ago (300+MB). If the clipboard is locked, it will give you the PID of the locking process. If you can't find that in normal task manager, as per the program's suggestion, open System Information (Start->Run->msinfo32), that has a more complete list of running tasks. It pointed me to Notepad++ and when I went there, NPP was behaving a little strangely (couldn't type in all open files, etc). I closed it and the clipboard freed up. – SSilk Mar 30 at 16:29

1

If you have Skype installed, then you will have to disable keyboard shortcuts in Skype. To do that, open Skype > Tools > Options > Advanced > Disable Keyboard shortcuts or Just Disable Ignore call Option as it uses the key bind "Control + C" which conflicts with Windows' copy to clipboard.

  • 2
    The question isn't about Skype, why do you bring it up? Also, please try to write complete English sentences, your text is hard to read. – vonbrand Feb 12 '13 at 13:25
1

I had this problem on a remote desktop connection. Even after trying @Ludovic's solution (Copy-paste stops working on Windows 7) it did not go away.

What worked for me was opening task manager and killing a process called RDP Clipboard manager

Not the answer you're looking for? Browse other questions tagged or ask your own question.