1

I have a problem with a Debian Jessie server running as an Intranet VMWare virtual machine.

This machine has been recently upgraded from Debian 7 Wheezy to Debian 8 Jessie (expecting continuing later to Debian 9 Stretch), and it was working fine in the previous release.

The problem is that it previously had a static IP address (192.168.0.63), but know it unexpectedly started using a DHCP IP assignment that seems to be hardly stuck on it and impossible to remove, even after uninstalling any package dedicated to contain a DHCP client.

This DHCP assignment seems to occur at boot time, as you can see on the following picture which shows the beginning of the boot sequence :

Picture of the very first lines displayed at boot

The closest already asked question that I found about it is on this page, but none of the provided solutions works, essentially because they all refer to modifying files that do not (or no longer) exists on this virtual machine, and most of the time not even the directories containing them.

I am stuck on this for days, I tried to remove all packages whose name contains the string "dhcp", and I even also tried to wildly delete all FILES on this machine whose name contains the string "dhcp", but nothing works.

I also looked inside the GRUB bootloader configuration, also without success.

This doesn't seems to be configurable from the VMWare virtual network interface, nor from its virtual BIOS.

The network interface always continues to get the unexpected IP address that I do not want.

Which package does contain this DHCP client that I do not want? How can I remove it? Do I have to recompile the kernel in order to revert to a statically assigned IP address? How can I kill all of these demoniac, available and possible DHCP clients and slay all of them definitively?

  • Are you sure you’re not accidentally netbooting? If not, check your kernel command line at /proc/cmdline. – Daniel B Jun 25 '19 at 13:30
  • /proc/cmdline contains the following: BOOT_IMAGE=/boot/vmlinuz-3.16.0-6-686-pae root=UUID=0ad23b20-d341-4c8e-a259-bf39f781efe3 ro quiet This doesn't looks like netbooting, AFAIK. – GingkoFr Jun 25 '19 at 13:37
  • 1
    Either way, it’s the kernel DHCP client. You won’t be able to get rid of it. You could try passing ip=off on the command line, but I think it’s better to investigate the root cause. – Daniel B Jun 25 '19 at 13:42
  • Are you telling me that DHCP is now hardly coded into the kernel and that it may no longer be possible to assign a static IP to the standard edition of Debian Jessie? What does mean “investigate the root cause” here? – GingkoFr Jun 26 '19 at 5:57
  • The kernel DHCP client is nothing new though, it’s over 10 years old. Normally, it does not activate by itself. And that’s what should be investigated: Why does it activate. – Daniel B Jun 26 '19 at 7:06
0

I'm not exactly answering the question as asked, but why not create a DHCP reservation on your DHCP server (192.168.0.1) that sets the address to 192.168.0.63? That will assign the IP address you want on the machine, and I think might effectively work around your problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.