0

I have a PC that was working with a static IP for months. All of a sudden today it stopped showing on the network and when I enter ipconfig in cmd it shows a different IP address than what is assigned statically. All other computers on the network are working as expected.

Example: IPv4 is configured as:

192.168.0.130  
255.255.255.0  
192.168.0.1

What is displayed in cmd with ipconfig:

169.254.142.33  
255.255.255.0  
192.168.0.1

If I set the IPv4 to Dynamic and do netsh winsock reset followed with ipconfig /release and renew after restart it works fine.

Any ideas on what caused this or how to resolve?

8
  • 2
    169.254.x.x is a self-assigned IP address - meaning it can't find its DHCP server, or that server isn't giving out an address when asked..
    – Tetsujin
    Jun 25 '19 at 15:40
  • @Tetsujin gotcha. How can I resolve this though? And how could this have happened to only this PC out of nowhere?
    – f1ss1on
    Jun 25 '19 at 15:53
  • Where does 192.168.0.130 come from initially? Is it a fixed assignment on DHCP or was it manually set on the local PC? If it came from a DHCP server, check the standard pool doesn't include that address, or that it's been given to another machine.
    – Tetsujin
    Jun 25 '19 at 16:02
  • 1
    'Assigned' where? & did you check the other things i asked?
    – Tetsujin
    Jun 25 '19 at 16:39
  • 1
    Then I'm stumped - if you manually set an IP address at the local machine, it should never even look for a DHCP server, so it should never fail & end up with a 169.254 address. Something really doesn't add up somewhere. [Smartest, btw, is to use DHCP even for static addresses, fix them at your gateway, keep the regular pool out of its way & allow everything to be handled centrally.]
    – Tetsujin
    Jun 25 '19 at 17:05
0

After countless reboots and changes, the solution ended up being turning on DHCP, which successfully received a new IP, and then turning static IP back on.

Seems like a weird bug where even though an static IP is set on the config dialog, windows is still searching somewhere for a DHCP to get an IP from.

Hopefully saves someone 30 mins of rebooting stuff (:

0

Having tried many suggestions I found here and elsewhere on the internet, what worked for me was connecting a USB ethernet adaptor.

I configured it with a static IP address and made sure I could ping another system. Then I moved the ethernet cable back to the built-in ethernet port. Lo and behold! Its static IP address is working again!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.