3

For some reason I'm no longer able to right-click my Windows icon. Normally I would use it as a shortcut to quickly Shutdown or Restart my computer, but now it requires two extra clicks.

  • All other taskbar icons (programs, etc.) function normally.
  • I've already tried restarting my File Explorer in the Task Manager

In the gif below you can also see that the cursor moves up/right every time I right-click, which is very strange.

  • this regedit may be relevant: answers.microsoft.com/en-us/windows/forum/all/… – mael' Jun 25 at 21:59
  • 1
    @mael' sounds like a perfect answer to me. Why not write it out? I'd vote it up if done properly (eg: not an answer with a link to that article, but actually copy/pasting it to preserve the data) – LPChip Jun 25 at 22:16
  • 1
    @LPChip you have fueled the procrastination fire that is my superuser participation – mael' Jun 25 at 22:32
  • 2
    I love the addition of the gif - I never realized the mouse behaves that way when you right-click the Windows/Start icon - even when it's behaving normally (mine does the same thing). – mael' Jun 25 at 22:41
  • added a couple more things to try to my answer – mael' Jun 26 at 1:30
4

Try following these steps:

  • Launch the Registry Editor as an administrator
  • Navigate to the following key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\ ImmersiveShell\Launcher
  • Click Edit
  • Click New
  • Select DWORD (32-bit) Value
  • Name it UseExperience.
  • Double-click the newly created item and set the value to 0.
  • Click OK
  • Close the Registry Editor and then restart your computer -- or just restart Explorer.

If that doesn't work, you may also try running Powershell as administrator with the following commands:

PowerShell -ExecutionPolicy Unrestricted
Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

There may be some errors you can ignore, but when it finishes it should be working... but if it's still not, there is a folder that may be corrupted or missing in your user profile:

%USERPROFILE%\AppData\Local\Microsoft\Windows\WinX

If you have access to a different machine that's not having issues, you should be able to copy the entire WinX folder into yours and see if that corrects the problem. If you don't have access to a different machine, there's a possibility that you can just create another user profile on your machine, see if your right-click is working there, and copy that folder over if it is.

References: Microsoft Answers, reddit, techmesto, and urtech.

  • +1 from me. Well done. :) – LPChip Jun 25 at 22:54
  • Thank you a lot for the quick answer. I've tried both solutions but there is no difference :/ – Sir Exotic Jun 25 at 22:58
  • Sorry it's still giving you trouble, I've found an additional powershell line that may help you (added to my answer); try running them in the order they are listed. I'll keep looking as well; it could also be a shell issue as described here by a person with a slightly different issue (fix action requires third-party software if you're open to that): tenforums.com/general-support/… – mael' Jun 25 at 23:05
  • You're the man @mael'! I created a different user on my computer and copied the folders from %USERPROFILE%\AppData\Local\Microsoft\Windows\WinX to my main account and restarted my computer. My start menu now behaves normally again! Unfortunately I can never unsee the cursor behavior when right-clicking the start menu, haha! Thank you so much for your time and persistence! – Sir Exotic Jun 26 at 8:43
  • happy to help! was an interesting issue – mael' Jun 26 at 14:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.