2

I recently downloaded the WSL Ubuntu app through the windows 10 app store. After the initial installation, everything seemed to work fine; I did nothing except add some aliases in .bashrc. I then tried re-opening the app, and I only get a blinking cursor.

Anyone else have this issue?

Edit: It seems solved, but I'm not entirely sure how. After attempting to uninstall the from the Ubuntu package from the start menu (and failing), I was somehow able to open the Ubuntu app from the start menu and get a command line. For some reason it seems like .bashrc had ended up with no permissions to read, right or execute. I'm not sure how this happened, or even if this was the cause, but after giving back all permissions everything seems to work normally.

6
  • Possible duplicate of How Do I Reset A Manual Installation Of Windows Subsystem For Linux?. This issue was caused by one of your commands. You should simply reset the WSL instance.
    – Ramhound
    Jun 25, 2019 at 23:15
  • This seems to apply to distributions installed outside the Windows store? Mine was through the W10 app store. i will edit into the main post
    – phi1123
    Jun 25, 2019 at 23:24
  • That particular answer absolutely applies to the Windows Store WSL instance..
    – Ramhound
    Jun 26, 2019 at 0:23
  • Anyways, my answer indicates to use, wsl --unregister <DistributionName> for 1903 instead of the (1709,1803,1809) command wslconfig /unregister <DistributionName>
    – Ramhound
    Jun 26, 2019 at 0:41
  • 1
    Just use wsl.exe or bash.exe.
    – Biswapriyo
    Jun 27, 2019 at 7:16

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.