2

At some point in the past, Intel thought it would be a good idea to add black margins to all output over miracast. And for the past year or so, the solution has been to open Intel HD Graphics Control Panel and disable it (as shown here; Microsoft Wireless Display: black border around image (screen image is scaled down) )

However, with Intel's new UWP app Intel Graphics Command Center coming with the new drivers, this option isn't presented anymore, in the UWP app or the old software. Is there any way to manually turn off this useless downscaling?

2 Answers 2

1
+100

I contacted Intel support, they were awfully slow when it comes to replying, not much they said was all that helpful.

However, I did by chance discover that the old Intel HD Graphics software is still installed, but hidden from the Start Menu, Search and the list of installed programs. It appears in my question I mentioned that this setting was missing in the old software, I don't recall exactly what the situation was there, but it's possible the option is hidden in this hidden software unless you are currently casting... 🤔

If you right click the desktop and open the Intel HD Graphics settings from there, it still uses the old software, which is unexpected, and from there you can change the "Wireless Display Scale" setting to a more reasonable 100%. Most other methods of finding and opening the old HD Graphics software no longer work and you can bet the setting will not be making its way to the new software, so here's to hoping when the old software is completely removed the driver removes the feature!

In the situation that the old software is missing from your desktop context menu, like in @joerno's case, there are two other solutions you can try...

  • Look for the old driver software, it may be installed in a directory similar to this... C:\Windows\System32\DriverStore\FileRepository\igdlh64.inf_amd64_df093c7b85af5a68\Gfxv4_0.exe
  • Try completely removing the Intel Driver using the DDU tool and install or roll back to a legacy version of the driver, and disable automatic driver updates while you're at it.

Now there's only one issue left, it's off center in the y axis by ~6 pixels! Way to go, Intel...

0

Some measures which worked in the past:

  • Installing the latest Intel driver

  • Matching the resolution to the native resolution of the monitor in Settings > Display > System

  • Matching the frequency to the native one of the monitor in
    Settings > System > Display > Advanced display settings > Display adapter properties

1
  • 1
    Good general advice, but this is a specific issue related to a """feature""" in the Intel HD Graphics driver. Commented Jan 16, 2020 at 10:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .