0

I have a UTF8 TSV file that contains text in various languages. If I start Excel 2016, then go to Open and then select the file, Excel will ask me about the encoding of the file, at which point I can choose UTF8 and open the document properly.

However, if I simply double-click on the TSV file, it opens it up without asking me about encoding, guesses it wrong and garbles the foreign-language text. How can I force it to ask me about encoding when opening a file this way?

Windows 10, in case it matters.

0

It seems that you should be able to make it work if your TSV file has a BOM. It essentially add encoding information in a few bytes at the beginning, which many programs can read correctly (or skip).

| improve this answer | |
  • So this means I need to add BOM to every TSV file before opening it. Unfortunately, this is not really a viable option for me: rather than having 1 file that I have to open many times, I have many files that I open once or twice. So messing with the BOM will take more time for me than just opening the doc manually as I described above. – I Z Jun 27 '19 at 13:39
  • There are tools that let you at least add the BOM easily (first hit on google radyakin.org/progs/bomtools), though it's definitely an extra step to take. Unfortunately without BOM Excel defaults to the system locale's codepage... – vlumi Jun 27 '19 at 14:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.