5

I opened VS Code today to find these annoying side margins taking up meaningless space. Considering I usually push the code to the side with other windows open, this really clogs up my screen. Does anyone know how to remove these, or at least know what they are called so I know what to search for ("VSCode side margins" and "VSCode gutter" did not seem to find any relevant results).

They possibly came from zen mode -- I believe that when the power went out last time I was using this computer I was in zen mode (ctrl+k z), but switching to and fro does nothing it seems.

EDIT: I have found a "solution", in closing the current folder and opening a new one, but will leave this question here as there's likely a better solution or someone knows what those margins are called/how to fix them properly. If a mod thinks otherwise, though, I don't mind this Q being deleted or closed.

Screenshot of VSCode with side code margins

4 Answers 4

3

I believe what you are referring to are the "sashes" coming from the "centered layout" view. To remove them just uncheck that view (on Os X it's under View/Appearance).

https://code.visualstudio.com/docs/getstarted/userinterface#_centered-editor-layout

2

Search for "ruler" as suggested here, Click on the link to edit the .json file, you can comment the "editor.rulers": lines.

1

you need to unable toggle word wrap on View:

on mac = command + Z

on windows = CTRL + Z

1
  • 3
    CTRL+Z == Undo (On Windows)
    – HackSlash
    Sep 23, 2019 at 15:38
1

I had the same problem. I fix it in de menu->view-apparence and there I uncheck center design. For me works, I hope for you too.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .