I have a web service that uses a self-signed certificate, so I need to install the certificate as a Trusted Root so that I can avoid all the security errors that having a self-signed certificate brings with it.

Using Windows 7, I'm going to:

Start > Internet Explorer > Run as Administrator > Tools > Internet Options > Content > Certificates > Trusted Root Certification Authorities > Import > (select file) > Next > OK, and Windows reports Import Successful

However, the import is NOT successful. The certificate does not show in the list of trusted roots, and certificate errors still show up.

If I import the certificate into the Trusted Publishers container, it imports correctly, but this does not solve my security errors.

Any ideas?

2 Answers 2


Thanks to the link posted by harrymc, I spent almost a day investigating this problem and figured out it was Windows Server 2008 default domain policy.

I suspect this problem only applies to Windows PC in a domain network environment. The default domain policy doesn't allow user to install additional certificate to Trusted Root Certification Authorities, but the worst thing is if you tried Windows 7 will still say "Import Successfull" anyway.

If you want to check whether your domain policy allow you to install certificate to Trusted Root Certification Authority, when importing the cert via certmgr.msc manually select the store and tick 'Show physical stores'. You should be able to place the cert into Trusted Root Certification Authorities\Local Computer

enter image description here

If you can't see above, then it has to be enabled via group policy editor on your Windows Server Domain Controller (client PC restart is required for it to take effect):

enter image description here

  • 15
    I noticed your answer was well written and not getting much love. I've awarded it a bounty since this sort of thing needs to be rewarded.
    – Journeyman Geek
    Oct 6, 2013 at 5:40
  • 8
    It's impossible to tell from the second screenshot how to find this setting; it's here: Computer Configuration\Windows Settings\Security Settings\Public Key Policies.
    – RomanSt
    Sep 2, 2014 at 2:20
  • 1
    @romkyns if you're on a domain controller server, that settings exist on multiple levels (some sort of cascading setting maybe?), hence why I didn't show it to avoid false sense of information
    – gerrytan
    Oct 7, 2014 at 1:44
  • @gerrytan I have no Local Computer option. :(
    – user66638
    Oct 31, 2015 at 12:11
  • @gerrytan, What OS are your screenshots?
    – Pacerier
    Nov 6, 2015 at 10:49

When configuring Telerik's Fiddler to handle HTTPS, I could not get root certificate installed. The error was "Failed to find the root certificate in User Root List". I solved the problem by temporarily turning off WebRoot, my antivirus program, then reattempting to enable HTTPS handling which installs Fiddler's root certificate. You may have to click the Action button on the HTTPS tab to remove/reset previous certificates before being able to create a new certificate.

  • Please do not post the same answer to multiple questions. If the same information really answers both questions, then one question (usually the newer one) should be closed as a duplicate of the other. You can indicate this by voting to close it as a duplicate or, if you don't have enough reputation for that, raise a flag to indicate that it's a duplicate. Otherwise tailor your answer to this question and don't just paste the same answer in multiple places.
    – DavidPostill
    Apr 24, 2017 at 14:24

Not the answer you're looking for? Browse other questions tagged or ask your own question.