2

I'm trying to set up a CentOS 7 file server using SMB, and I'm running into a bit of a snag. I can ping the server just fine from my Windows 10 machine:

Pinging green-lightning [192.168.1.191] with 32 bytes of data:
Reply from 192.168.1.191: bytes=32 time<1ms TTL=64
Reply from 192.168.1.191: bytes=32 time<1ms TTL=64
Reply from 192.168.1.191: bytes=32 time<1ms TTL=64
Reply from 192.168.1.191: bytes=32 time<1ms TTL=64

Ping statistics for 192.168.1.191:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms

But when I try to access the server in File Explorer, I get this error:

Windows can't find '\\green-lightning'.  Check the spelling and try again.

I tried connecting to the IP address, but got the same error. I also tried putting my username in the public zone in the server's firewall, and restarting the SMB service.

Using TCPing to check to see if port 445 on the server was open revealed that it was:

Probing 192.168.1.191:445/tcp - Port is open - time=8.373ms
Probing 192.168.1.191:445/tcp - Port is open - time=8.301ms
Probing 192.168.1.191:445/tcp - Port is open - time=7.904ms
Probing 192.168.1.191:445/tcp - Port is open - time=7.636ms

Ping statistics for 192.168.1.191:445
     4 probes sent.
     4 successful, 0 failed.  (0.00% fail)
Approximate trip times in milli-seconds:
     Minimum = 7.636ms, Maximum = 8.373ms, Average = 8.054ms

TCP port 139 was open as well.

I'm obviously doing something wrong here; what is it?

  • Is port 445 open? You can check with tcpping, netcat, or telnet. – Bob Jul 2 at 0:45
  • Yes, it is. I added the results to the question. – PSDuckie Jul 2 at 0:57
  • Maybe also check TCP 139 and UDP 137/138 (you can't 'ping' UDP but you can at least check it's not blocked by your firewall rules - whether explicitly or by a default deny without any accept). – Bob Jul 2 at 1:03
  • TCP 139 is open. I recently got a new router so I'm going to have to figure out how to check UDP with it. – PSDuckie Jul 2 at 1:09
  • And it looks like the UDP ports are open as well – PSDuckie Jul 2 at 1:28
2

Just checking; are you doing SMBv1? With windows 10 SMBv1 is disabled - so try enabling it from "Turn Windows features on or off" -> "SMB 1.0/CIFS File Sharing Support"

  • That was something I had thought to try. Unfortunately, enabling that had no effect. – PSDuckie Jul 2 at 7:15
  • Turns out I only had part of SMBv1 installed. Installing the other parts fixed the issue. – PSDuckie Jul 2 at 15:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.