0

So whenever I try to update my windows 10, I get an error saying there were some problems trying to install updates.

I tried to fix it by follow this guide https://www.youtube.com/watch?v=6lnl80K9HGA but on the last step I get 'Access is dienied' error.

Does anyone know how to fix any of this?

Windows update error

Access is dienied error

Added more info:

Windows Update service configuration

Information from winver

  • Please edit your question to include what version of Windows 10 you are running. You should indicate what the last cumulative update that was installed is exactly. You should also provide the relevant information from winver. Your question cannot be answered without this information. – Ramhound Jul 2 at 21:35
  • @SimonG: Check the Windows Update service configuration. To do so, right-click Start, click Run. Type cmd /k sc qc wuauserv. Copy the output and post it here. – w32sh Jul 3 at 3:59
  • Sorry for the lack of information, just added it the post. – SimonG Jul 3 at 13:09
0

Ok so I've been posting this everywhere....try this: Open this link to Download the latest Windows 10 ISO : https://www.microsoft.com/en-us/software-download/windows10 You have two options: Download the full ISO using the media creation tool or Click update now ...and let us know what happens !!

New contributor
Elmo is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. - From Review – Rajesh S Jul 9 at 6:08
  • @RajeshS i am new here , thanks for the tip. – Elmo Jul 9 at 6:29
  • @RajeshS did u get my answer deleted or something ?? I already edited it..so what is this FormReview ..How do i remove it from that form review page – Elmo Jul 9 at 7:01
  • ,, While review the whole text appears ,,, and during Review for Editing, the Reviewer can decide to approve or not ! – Rajesh S Jul 9 at 7:36
  • That worked! Thank you :) – SimonG Jul 9 at 19:18
0

If you get access is denied error, use the default admin account and update from there. You can also fix your user's permissions or make a backup and start over.

From elevated command prompt, type
net user administrator /active:yes

You still need to restart the Windows Update service.

Log in as Administrator.
Open Administrative Tools from Control Panel.
Double-click Services.
Authenticate.

Find the Windows Update service, right-click Properties.

On the General tab, next to Startup type, make sure that Automatic is selected. Next to Service status, check to see if the service is started. If it is not, click Start.
Authenticate.

Now check for updates as usual.

Microsoft Support Thread

  • The thing is that I am using the default admin account and yet still get the access is denied message – SimonG Jul 2 at 19:10
  • @SimonG - You made no mention of the fact you were using the built-in Administrator account. You should edit your question, to reflect that fact, that is vital information necessary to answer your question. – Ramhound Jul 2 at 21:34
0

(From: Fix: Windows Update Error 0x80070422 in Windows 10)

Open admin Command Prompt and execute the following command:

sc config wuauserv start= demand

Restart Windows and see if the Windows Update service starts correctly.

If you receive Access Denied error when running the above command, try resetting the Windows Update service registry key permissions to default.

Download RegASSASSIN from Malwarebytes and run it. Input the following registry key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\wuauserv

In RegASSASSIN, don't forget to UNCHECK the Delete registry key and all subkeys checkbox before clicking on the Delete button.

You can use RegASSASSIN utility from Malwarebytes to reset the registry permissions for this key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\wuauserv

enter image description here

Now, see if you can change the Windows Update service Startup type using the Services MMC or Command Prompt.

  • Doesn't work, I still get an access is denied error in the cmd – SimonG Jul 3 at 13:36
  • Are you sure you're running that command from an Administrator Command Prompt window? To open one, type cmd.exe start, right-click Command Prompt (from Start search results) and click Run as Administrator. – w32sh Jul 3 at 13:49
  • Yea I do just that and still get the error – SimonG Jul 3 at 14:18
  • Pls check my updated answer. – w32sh Jul 3 at 14:39
  • I did that with RegASSASSIN and still the access is being denied – SimonG Jul 3 at 21:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.