1

I like creating multiple Spaces on macOS (like different Desktops on Linux). I also like to keep apps in their own spaces: Browser in desktop 1, editor in 2, and email app in 3.

So I create 3 spaces by swiping 4 fingers up, then click + button to add spaces.

Then in first space I right click on the Dock icon of my browser and select “Options > This Desktop.” I switch to the other Spaces and do the same thing for the other apps.

Everything is working fine, until some time later I notice that browser is now in desktop 3, editor 1, and email in 2. The Dock options menu shows that the selections have also changed.

How can I make the options stick?

1

1 Answer 1

0

Copied directly from my existing answer at https://apple.stackexchange.com/questions/214348/how-to-prevent-mac-from-changing-the-order-of-desktops-spaces/214349#214349

System Prefs > Mission Control
Uncheck Automatically rearrange Spaces based on most recent use.

enter image description here

This will fix the order of all your regular Spaces - but not Fullscreen spaces, which always go to the right of existing numbered Spaces.

Note this cannot fix the Mac confusing which external screen is which. That's not user-controlled at all, & seems to occur mainly [though not always] when the external screens are identical.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.