0

I had been using Windows 10 Mobile Hotspot to successfully join two laptops together for a couple of months, but recently it has stopped working and my (somewhat limited1) skills and Windows' diagnostics have not been able to get it going again.

Details

  • Dell XPS-15 Laptop running Windows 10 Professional (10.0.17763).

    • Wired ethernet connection (via Dell Thunderbolt dock) to the internet.
    • Mobile Hotspot enabled over Wi-Fi, sharing above connection.
  • Sony VAIO-X Laptop running Windows 7 Professional SP1.

    • Connected over Wi-Fi to the Mobile Hotspot provided by the Dell.

After a couple of initial problems getting all the right settings in place, I was able to:

  • Connect to the internet from the Dell.
  • Connect to the internet over Wi-Fi from the Sony using the mobile hotspot.
  • File-share in both directions between the Sony and the Dell over Wi-Fi.
  • RDP from the Dell to the Sony over Wi-Fi.

The above system is what I use in a serviced office space. At home, I mainly use the Sony and connect to my home broadband over Wi-Fi. For the most part, the Sony would switch happily between connecting to my broadband when at home and the hotspot in the office.

The Problem

A short while ago, the Sony stopped (reliably) connecting to the hotspot. As far as I can remember, I had not (knowingly) changed any network-related settings on either machine, nor explicitly updated any drivers (although it's possible this did happen through Windows Update on the Dell). I seem to remember that at some point Windows' diagnostics on the Sony indicating it couldn't get an IP address, so I tried ipconfig /renew and using this when a problem occurred seemed to fix things for a while.

Since the initial problems, the ipconfig /renew on the Sony no longer works: it returns (after quite a long wait):

An error occurred while renewing interface Wireless Network Connection : unable to contact your DHCP server. Request has timed out.

Attempts to Fix

Since the "renew" command stopped "fixing" things, and with the help of on-line searches / StackExchange, I have tried running all (obviously) suitable Windows' diagnostics on both machines, and they don't indicate problems. I have inspected settings of various components2, but none (by my somewhat limited knowledge1) looked wrong. Where possible, I have tried disabling/enabling components to "reset" things, but this hasn't made any noticeable difference. Both machines have been rebooted a number of times, and the Dell is up-to-date with both Windows and Dell.

Current State

  • The Sony successfully makes a Wi-Fi connection to the Dell, so the Wi-Fi adapters on both are working and (at least somewhat) configured correctly. However, nothing shows under the Devices connected: section of the Dell's Mobile Hotspot settings page.

  • pinging by name from either machine cannot find the host; pinging what ipconfig reports as the other machine's IP address gives PING: transmit failed. General failure. from both machines.

  • If I try connecting my Android 'phone to the Dell's hotspot, it seems to connect at the Wi-Fi layer but, after a number of attempts, fails with "Failed to obtain IP address.".

  • If I activate the Mobile Hotspot of my 'phone (to share its 4G connection) then I can successfully connect to it (and the internet) from the Sony.

To me, the latter two results suggest the problem is more likely to be with the Dell than the Sony.

Conclusion

While the Wi-Fi link-layer of the Mobile Hotspot is working on the Dell, some part of the higher layers are not. In particular, it does not appear to be issuing IP addresses. Whether this is because DHCP is not running over the hotspot, or something more fundamental at the IP level is not working, I don't know.

Can someone suggest a more directed approach to diagnosing/fixing the problem?


1 I'm fairly technical (programmer for 25 years including writing TCP/IP client/server software at the socket() level). However, my "in depth" knowledge of which bits of Windows affects which other bits of Windows as far as networking is concerned is much more limited.

2 I've not posted specific settings as I feel there are too many possible things I could post, and I'm not sure which are most relevant. However, I'll gladly add any if requested.

3
  • It is bug in latest Windows 10 1903 update. There is no solution for now except use other WiFi adapter (dlin one works good, also some others may). Jul 3, 2019 at 9:35
  • @MikePetrichenko Thanks (I suppose :-() for that... do you mean a different physical Wi-Fi adapter (e.g. USB) or a different WiFi driver? Presumably "dlin" is "DLink"?
    – TripeHound
    Jul 3, 2019 at 9:41
  • Yes, I mean different physical USB WiFi adapter. And yes, I meant DLink (sorry for mistypoe). I have DWA-131 but it doe snot support WFD but looks like able to create Mobile Hotspot. Not sure about link quality. But works. Also I PCI DWA-525. This one works perfectly and supports all the things. Also our customer reported that some realtek WiFi chipsets also work without problems . Or simple rollback to previous Windows 10 version. Jul 3, 2019 at 10:51

0

You must log in to answer this question.

Browse other questions tagged .