0

I'm trying to connect a Telit LEU910C1-EU modem to get a data connection (over LTE). The module is used via a CM3, the modem itself is plugged into a usb hub. While tinkering around I got the following weird behavior:

  • On a Ubuntu Laptop, I can use the modem just fine with ModemManager and NetworkManager. (see below for exact steps)
  • On the Pi though I seem to get no errors and NetworkManager tells me I'm connected. When doing a ping -I wwan0 8.8.8.8 though it blocks indefinitely.

I already tried many different SIMs (including the one in my smartphone) and even swapped the modem. One weird thing is also that the whole Pi seems to be unresponsive for a few seconds after starting the ModemManager and sometimes the ethernet doesn't seem to be working anymore after.

I tried to summarize all important logs in this Gist:

https://gist.github.com/sahib/3a2d7951aec59ffd23f3d1eef60cc450

(This include all relevant software version, they are the same as on on the Ubuntu laptop, except the kernel).

Those are the steps I use to setup the modem itself:

$ sudo systemctl start ModemManager
$ sudo systemctl start NetworkManager
# Check if the modem was recognized:
$ mmcli -L
# Check the status of the modem, if it shows "registered", continue.
$ mmcli -m 0
# Actually add the connection:
$ sudo nmcli c add type gsm ifname cdc-wdm0 con-name telit apn bicsapn
# Test the connction. This will block forever or yield "not reachable"
$ ping -I 8.8.8.8

Did anyone have similar issues or can help debug that further?

1

In newer releases NetworkManager will take over the MTU size from ModemManager automatically: https://gitlab.freedesktop.org/NetworkManager/NetworkManager/-/merge_requests/499

1
  • Welcome to Super User! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference.
    – MMM
    May 7 '21 at 13:04
0

Solved it.

There are two things to check:

  • systemd-networkd seems to interfere with NetworkManager. Disable it by using:

    $ systemctl disable systemd-networkd (reboot after)

  • The MTU size was wrong. For LTE the maximum size seems to be around 1430. See mmcli -b $(number of your bearer from mmcli -m 0).. Lower it via ip link set dev wwan0 mtu 1400. It should work automatically after.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.