2

A web app I use uses Ctrl+Shift+0 through 9 as particular keyboard shortcuts. Ctrl+Shift+0 has never worked for me, but 1-9 always did. I rarely had to use 0, so I just sort of ignored it. However, suddenly Ctrl+Shift+1, +3, and +8 have also stopped working - possibly right after upgrading to the latest version of Windows 10; I'm not exactly sure on the timing of when I updated and started noticing this behavior. This is happening across multiple browsers, and it's not the app itself that's having issues as going to keycode.info and checking to see which key presses are being registered confirms that those four specific number keys are not being registered when Ctrl+Shift are also being held down.

I also doubt it's a hardware issue as I used AutoHotkey to map that specific sequence to my function keys and I'm getting the exact same behavior as when actually physically pressing all three keys. It seems like Windows itself must be overriding that key sequence or something, but I can't figure it out.

0

The Ctrl+Shift+0 combination(s) are often used for switching input languages.

To check and modify:

  • Start Settings
  • Click Devices > Typing
  • Click Advanced keyboard settings
  • Click Input language hot keys
  • Select a combination and click Change Key Sequence...
  • If you see your key combination, to disable set both radio buttons to "Not Assigned", or set it to any other sequence
  • Click OK.
|improve this answer|||||
  • 1
    I tried this and it had no effect, unfortunately – Devin Jul 3 '19 at 17:59
  • Were these shortcuts used among the language hot keys? – harrymc Jul 3 '19 at 18:25
  • For the Between input languages action Control + Shift was assigned to Switch Input Language, and I selected the Not Assigned radio button and saved. The only other action available was To English, and that was not enabled. If it was, Ctrl + 0 was the default shortcut, but it was and is grayed out – Devin Jul 3 '19 at 19:48
  • 1
    Have you effectively downgraded Windows 10 with that reset, from 1903 to an earlier version? – harrymc Jul 4 '19 at 6:31
  • 1
    In that case the only solution I can see is to wait for Microsoft to fix this new bug. – harrymc Jul 6 '19 at 16:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.