1

Drives C: and D: are taken by the hard drive and the DVD. So the first available drive for a USB stick is E:. When I plug any USB into the computer, it does not show in File Explorer or in the "My PC" view. But, if I manually tell Explorer to go to "E:", it works fine. Also, if I plug a second USB drive into the computer with the first one still in, it immediately shows up in all views as drive F:. So, only drive E: is not automatically recognized.

Please note: the USB stick itself is fine and not corrupted; autoplay is enabled and set to open Explorer to view files. The problem is only in automatically recognizing drive E:.

Another note: this used to work fine. At some point, I was given an option to change how it reacted to drive E: and I changed it, but I can't remember what I was asked or what I did. There must be a setting somewhere to reverse this.

5
  • More info - the drive (E:) shows up in Disk Management as healthy; the latest driver is installed. Also, if I reverse the order of plugging in USB drives, then the second drive plugged in always shows up correctly as drive F:. It is only the first drive plugged in that has to be accessed manually.
    – Ottprof
    Jul 3 '19 at 16:06
  • Try to remember what option you changed for the drive.
    – harrymc
    Jul 3 '19 at 16:16
  • Maybe review these steps - groovypost.com/howto/…
    – xpkiro
    Jul 3 '19 at 16:54
  • What happens if you assing the stick a different drive letter and then remove it an stickt it back in? Will it keep that drive letter? Do you have any network drives? Jul 3 '19 at 19:49
  • Yes, mit keeps the new drive letter and continues to work. Then when I stick another drive in, it defaults to E; and again doesn't work.
    – Ottprof
    Jul 4 '19 at 20:03
0

I found the answer: Unplug the drive(s) if it is plugged in.

Then:

Device Manager > View > Show hidden devices

Expand "Disk drives"

Right-click and select "Uninstall device" and uninstall all grayed out entries for the drive(s)

Close Device Manager and plug the drive back in

1
  • This solution worked for a while then stopped working. So I mapped drive e: to an unused network address. Now the system doesn't use E: and everything works.
    – Ottprof
    Jul 4 '19 at 20:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.